Hello Guest it is July 05, 2020, 04:18:46 PM

Author Topic: XYZ will not Back Off during Ref All after hitting Home Micro Switches.  (Read 2735 times)

0 Members and 1 Guest are viewing this topic.


Hi,

Just wondering if somebody can help me with the Home Switches issue on my CNC Router.

During "Ref All" XYZ moves normal towards the XYZ Home switches.
XYZ trips all the home switches but they don't Back Off. (All of them).

All XYZ Ref All LED Green Lights are on.
Machine Coordinance are all at Zero.

If I go to "Diagnostics", XYZ all XYZ yellow lights are ON.

On "General Config." Home Slave with Master Axis is Unchecked.

I know it is not all the XYZ Micro Switches BUT I bought new ones and changed all of them anyway.

Debounce Interval was adjusted to 2000. (I changed the Debounce at the General Config. Page.) Is this the place to change it?

They way I used the machine now is, I jog away from

the XYZ Micro switches then I Zero Work Coordinance.
If I Jog XYZ Axis away and click on "Goto Z", everything is normal. XYZ goes to Zero.

If I Ref All, XYZ will Ref All but will not Back off. (3 Yellow Lights are On).

Everything is working before but somehow I must have touched something and cannot figure to go back.
Thanks for any help.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
It sounds like your switches are bouncing and thus Mach sees them open, backs off, they close instantly but really are just bouncing about the open/close point.
I would have thought 2000 debounce would have helped but maybe as a test try 5000 to see.

BTW are yoiu using the parallel port or an external controller?

Hood
I have tried debounce up to 12,000. I read someplace that debounce is for parallel port.

I am using a WXhc Mach 3 Motion Control Card. it is a USB.
This is all brand new. I built the router myself.

I have replaced all 3 XYZ Home Micro Switches. (2 times). I don't think it is a Micro Switch.

Everything was working before but I had it set in Metric.
I have worked with Inches all my life so I decided to re-install Mach 3 and set it up in inches. Also at that same time, I bought 2 screen sets and was playing with them.
Not sure what I touched.
Everything is working except for XYZ not backing off during Ref All.

I have a spare desktop, I was thinking of installing Mach 3 in mm, try it and see what happens.
Any other idea?








Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Ok that is what I thought may be the problem and why I asked if you were using the PP or an external controller.
You will need to look in the plugin for your controller and see if there are settings for the home switches, there may also be filtering options there, similar to Debounce.
Hood

I got it working now after a few weeks of playing with this.
XYZ will now Back Off after Ref All.

On the "Plugin Control" there is an option to select the WXhc Mach 3 Motion Control Card.
Double click - Dialogue Box pops out - Select "Dual" on Homing.
Also on the Homing Pull Off. you need too enter 1, if you want the axis to back off 1" or 2 or 3.........etc.