Hello Guest it is November 13, 2019, 10:49:08 PM

Author Topic: New Plasma Screen Detail help  (Read 3786 times)

0 Members and 1 Guest are viewing this topic.

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
New Plasma Screen Detail help
« on: May 04, 2015, 11:35:33 AM »
Hi all.

This is probably a little nit picky but I'm getting a light witness lines below and to the right of my DROs and inputs. I set the Background and DRO color to the same color I had set in cad when designing the background. Also the size in the Machscreen shows larger then when I actually run it in Mach3.

Another issue I'm have is with the LED indicators I have positioned inside my Image Buttons. The Reset Button LED works fine but the Start LED would only show for a split second unless I set it to Blink.

Thanks for any help.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: New Plasma Screen Detail help
« Reply #1 on: May 04, 2015, 11:48:49 AM »
1) Turn off Boxed DRO's and Graphics in General Config, and restart Mach3.

2) You can't put LED's over image buttons and have them work reliably.
What you need to do is incorporate create a dual state LED image that contains both the button and LED.
Make that your LED, and place it first.
Then, on top of the LED, place an image button with a transparent (blank) image. It can be a small 10 x 10 pixel .png.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Bobo

*
  •  41 41
    • View Profile
    • Haus Metalworks
Re: New Plasma Screen Detail help
« Reply #2 on: May 04, 2015, 11:58:51 AM »
Wow! That was a fast response.

Turning off Boxed LED's did the trick. I'll have to work on the Buttons.

Thx

Offline mike^3

*
  •  117 117
    • View Profile
Re: New Plasma Screen Detail help
« Reply #3 on: May 16, 2015, 03:58:40 PM »
Hi bobo, did you ever finish your screen? Would you mind sharing it? Thanks

Mike
Re: New Plasma Screen Detail help
« Reply #4 on: May 18, 2015, 08:05:11 AM »
I put up a copy in Mach Screens, Work in progress

I must have two logins set up. Look for the post from Pompus.

http://www.machsupport.com/forum/index.php/topic,30128.new.html#new