Hello Guest it is April 11, 2021, 06:56:47 PM

Author Topic: Mach3 has "Lost" xbox controller  (Read 1871 times)

0 Members and 1 Guest are viewing this topic.

Mach3 has "Lost" xbox controller
« on: April 30, 2015, 06:00:06 PM »
I finished my CNC build about a month ago. I am using the latest version of Mach3 (fully licensed)

I had a Microsoft Xbox controller working great. Today I moved some stuff around and unplugged the controller while doing so. It then was plugged back into the same USB port. Now Mach3 will not recognize (see) the controller. Nothing changed in the setup. I've tried un installing and re installing everything. I cannot figure out why it stopped working.

Info:
Windows 7 32bit
Mach3 V66
Microsoft XBox Controller
DirectX v 11
DXDiag says everything is good. I also got the Vendor ID and Product ID here
Windows reports controller as working

When I go into the XBox360 Controller Plugin configure screen, it show no controller found and the ID's are all 0's

I remember that the first time I installed the plugin I had to manually input the ID's.
I tried to do so again, but they will not stick. Every time I input the and exit out, when i go back in they are back to all 0's

Really stumped.

George M
Re: Mach3 has "Lost" xbox controller
« Reply #1 on: May 03, 2015, 06:43:42 AM »
 Hi George,

          I know this is no help, but I am running into the same problem. If you find a solution please post.
Regards
Charlie M.
Re: Mach3 has "Lost" xbox controller
« Reply #2 on: May 03, 2015, 09:51:36 AM »
I ended up re installing Mach3 and the windows drivers. What I did find out was if you enter the ID's manually, do not enter the 0x -- only the 4 digit ID.