Hello Guest it is May 08, 2021, 09:42:01 AM

Author Topic: Ethernet Smooth Stepper Problems - Stops at the same place EVERY time  (Read 5359 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Sorry, Plugin Control menu.

Hood
4 hz

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Could well be your problem, set it to 1K and see.
Hood
heres the problem with set it to x and see,.... It takes a day to build my blank, it takes a day to rough mill, then I start the large segmented files, which take 2 days, it might wait till the 4th day in this process to crash, and then, oops, i guess that didn't work either.

After weeks of this, I not so keen on guessing if something will work

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Up to you.
Hood
This is my point, if the only way to determine if something is working correctly, is this type of arduous trial and error, the product does not seem ready for real commercial work, where users don't have weeks to waste horsing around guessing what might work.



Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Well unless things have changed the frequency is not set to 4K as default , there is a reason why it is not set to that, the reason is it takes a very stable system to be able to run at that frequency. With 4K set the buffer is probably only 1/4 second, so it doesnt take much to interupt the flow and you end up running out of buffer.

Hood
I have not changed the frequency, I will have to look into where the setting came from. What is the recommended default, is is 1?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
I think default is/was 1Khz.
I run mine at 2KHz if I recall. Did try at 4Khz for a while but "ran out of data" errors occasionally happened.
Hood
I did lower the frequency to 1hz and also found a computer setting that allowed windows to turn off the ethernet port to save power, go figure. The developer of smooth stepper gave me the computer heads up and a couple of nice support calls and was very supportive. Fixing those to things seems to have solved the problem.... I hope.