Hello Guest it is September 27, 2020, 12:06:16 AM

Author Topic: Cycle Jog Step/Jog Mode not working  (Read 5720 times)

0 Members and 1 Guest are viewing this topic.

Cycle Jog Step/Jog Mode not working
« on: April 06, 2015, 06:31:32 AM »
 ??? ??? ??? I am just starting out with Mach3/cnc stuff and at a loss.

 If I press TAB the MPG MODE come on. If you look at the Jog Mode (no light). Cycle Jog Step will not move through the steps in the Gen config. Key board will jog only in motor setup.

I have some more question on getting this thing started//running.

 Like the homing. grrrrr.  But one thing at a time. I have one of those TB6560 4V3 boards. I had to jump wires from where the parallel port is first connected to the board.  20 to com, 10 to LPT10, 11 to LPT11, exc..... Now the limit switches, Estop and probe are working.

Regards
Gizmo

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Cycle Jog Step/Jog Mode not working
« Reply #1 on: April 07, 2015, 02:01:13 PM »
If you attach your xml I will take a look and see if I can figure out your problem.
Hood
Re: Cycle Jog Step/Jog Mode not working
« Reply #2 on: April 07, 2015, 03:07:46 PM »
 The cnc table is my main file, the mill is the one I try things. In mill the jog light is on cnc table it is not Been trying to figure that out.

 One of these days I will get this thing figured out.

 Gizmo

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Cycle Jog Step/Jog Mode not working
« Reply #3 on: April 07, 2015, 03:28:02 PM »
Ok on the main screen in Mach, lower middle you will see a button that says Jog On/Off, you have it switched off, it needs to be On.
Hood
Re: Cycle Jog Step/Jog Mode not working
« Reply #4 on: April 08, 2015, 12:56:16 AM »
 :-\ I call it hidding in plain site.  Thanks. I tried to send both the cnc table and mill.xml but this program would not let me. ??

 If you could I have some more.

I have the  Persistent Offsets checked (I think) but I lose my home 0,0 everytime I turn off/on.

The othe is I went through the file (I am at work so I do not have the file name) that tells you to go through your computer. That tell you to turn this on/off, set this to, and so no. I still have enough noise to stop it from doing the set all home. Got any ideas?

Gizmo

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Cycle Jog Step/Jog Mode not working
« Reply #5 on: April 08, 2015, 04:38:37 AM »
The forum only accepts a file name once so to attach xml's etc you will have to rename to something unique.

Losing machine zero could be an ESS issue, do you have Home switches set up? If so you should Home the machine and the Zero positions for work offsets should be as previously.

Not really sure what you are asking with the other question.
Hood
Re: Cycle Jog Step/Jog Mode not working
« Reply #6 on: April 08, 2015, 11:20:22 AM »
Losing machine zero could be an ESS issue?????

I chained my limiting, com to c to nc, an so on.  All but the last one. That one is flipped, nc goes to lpt13 so you do not loss the last limit. I figured if I turn off the limits and on the homes you would not get the Estop. It works B-) somewhat. (if I am with in3-5mm)

The other part of my last question was about noise on the line. Scott thinks it is stopping my homing. It only moves 3-5mm stops an zeros.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Cycle Jog Step/Jog Mode not working
« Reply #7 on: April 08, 2015, 06:15:35 PM »
Regarding the ESS, I seem to recall when I start a machine that has an ESS or USB SS, then the DROs will display a random value. That does not matter to me because I have home switches and when I home the machine then the  offset previously set will be correct.
I do not know how the ESS works if you do not home the machine so someone else would have to chime in on that or you could ask Greg on the Warp9 forum.

I am not sure what you are meaning about the limit switches. Normally you would daisy chain all switches together and use the NC contacts to do so. You would then set up the port and pin numbers in Mach for the limits. You can also set the home switches up to the same port and pin number if you wish, what would happen in that case is the limits would be treated as home switches when you ask Mach to RefAll. After the machine has homed the switches would then be seen as Limit switches again.

Yes if you are pressing RefAll and the axis only moves a short distance then sets Home, then it is almost certainly noise that is the problem.
Ideally you want all low volt signal wiring shielded and the shield correctly attached to ground at one end, all shields should terminate at a single earth point.

Setting some filtering for the home switches in the ESS plugin may help, do not set it too high or your switches may not be seen when they should, try maybe 5 or so and see if that helps.

Hood