Hello Guest it is July 11, 2020, 05:43:47 PM

Author Topic: wizards and feedrate per rev  (Read 1208 times)

0 Members and 1 Guest are viewing this topic.

wizards and feedrate per rev
« on: April 01, 2015, 10:02:10 PM »
Hello chaps
I am using a wizard from the wizard library called idboring

it seems to me that as a default that this wizard initializes feed per minute in the
line  no 1
question. how can i get the wizard to initialize "feed per rev"
when the code is prepared.
think of the trees-- use both sides of the computer paper

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: wizards and feedrate per rev
« Reply #1 on: April 02, 2015, 06:23:54 AM »
Generaly,

Modify the button script so that it codes G95 instead of G94.

Operator>Edit Button Script, select Post Code button, look thru the script and change accordingly

You can have wizards, done by different people, which do the same task and but the scripting varies ie; some default to your configuration, so provide choice of feed mode, some don't, some don't allow modification of the script.........so need to look at the scripting.

RICH
« Last Edit: April 02, 2015, 06:35:12 AM by RICH »
Re: wizards and feedrate per rev
« Reply #2 on: April 03, 2015, 10:27:28 AM »
Thanks rich - i did it with the idboring wizard and the setup string was changed after posting code
as was suggested
I am  posting another topic about pulley ratio- please have a look at ity

best regards

fred
think of the trees-- use both sides of the computer paper