Hello Guest it is October 16, 2019, 06:57:35 PM

Author Topic: Lua 5.3? Yes, No, When?  (Read 1631 times)

0 Members and 1 Guest are viewing this topic.

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Lua 5.3? Yes, No, When?
« on: March 01, 2015, 07:34:05 AM »

Is the version of Lua in MACH4 user upgradable? If not, then is there a schedule or ETA for implementing new versions of Lua?

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: Lua 5.3? Yes, No, When?
« Reply #1 on: March 09, 2015, 02:30:23 PM »
It would be good to get an answer here because the difference between 5.2 and 5.3 is more than yet another bell or whistle.

Integer data type was added. 5.2  is all floats. That will have a large impact on any math code, one might imagine.

Creating integers out of floats is something of a PIA and I would speculate that the integer types will speed up Lua code significantly.
Re: Lua 5.3? Yes, No, When?
« Reply #2 on: March 09, 2015, 02:41:38 PM »
This is likely dependent on the release of Lua 5.3 support by the wxLua wrapper
which provided the binding between wxWidgets and Lua.

http://wxlua.sourceforge.net/
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: Lua 5.3? Yes, No, When?
« Reply #3 on: March 22, 2015, 07:38:57 AM »
This is likely dependent on the release of Lua 5.3 support by the wxLua wrapper
which provided the binding between wxWidgets and Lua.

http://wxlua.sourceforge.net/

Not quite yet:

"wxLua can be built against wxWidgets 2.8.x, 2.9.x and Lua versions 5.1, 5.2, and LuaJIT."