Hello Guest it is June 03, 2020, 02:57:20 PM

Author Topic: MDI screen  (Read 4121 times)

0 Members and 1 Guest are viewing this topic.

MDI screen
« on: February 09, 2015, 05:56:34 AM »
Hello Everyone,

           I have my cnc router setup and I can jog the axis everything is working. I do not have the home/limit switches configured yet. So I go the the MDI screen if I enter G0 x23 lets say I would think I should get some movement. however I do not. Is there something I have to setup? Thanks

regards Charlie
Regards
Charlie M.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: MDI screen
« Reply #1 on: February 09, 2015, 05:39:14 PM »
Assuming you can jog then you should get movement from MDI, only thing I can think of is you have the option in General Config set to stop programmed moves on Input 1.

Hood
Re: MDI screen
« Reply #2 on: February 09, 2015, 07:59:45 PM »
Hi Hood,

            Can you tell me where exactly that setting is? Is in at Program safety?

Charlie
Regards
Charlie M.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: MDI screen
« Reply #3 on: February 10, 2015, 02:45:57 AM »
Yes, lower left General Config page. It should not be chosen unless of course you are wishing to use it.
Hood
Re: MDI screen
« Reply #4 on: February 10, 2015, 05:30:54 AM »
 Hi Hood,

    Its not checked. Does it matter that I am suing the demo version?
Regards
Charlie M.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: MDI screen
« Reply #5 on: February 10, 2015, 07:08:11 AM »
No, demo works fine with only a few limitations such as Run From Here doesnt work, 500 line limit in Mill (50 in lathe?) Threading in Lathe and THC in plasma I think.

If you attach your xml I will take a look.
One thing, when you command the move via MDI, do the DROs count as if the axis is moving?

Hood
Re: MDI screen
« Reply #6 on: February 10, 2015, 07:12:39 AM »
Hi Hood,

       no the Dros do not move. When I type in G0 X45 lets say, nothing happens and the history window pops up with nothing in it. I will post my xml later today. Thanks.
Regards
Charlie M.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: MDI screen
« Reply #7 on: February 10, 2015, 07:13:26 AM »
Are you pressing Enter on the keyboard after typing the G0X45?

Hood
Re: MDI screen
« Reply #8 on: February 10, 2015, 05:16:08 PM »
Yes.
Regards
Charlie M.
Re: MDI screen
« Reply #9 on: February 10, 2015, 06:24:24 PM »
Hood,

  Thanks for the help. here is my xml file. I had to rename it. just remove the .txt. Thanks for the help.

Regards
charlie
Regards
Charlie M.