Hello Guest it is October 16, 2019, 09:02:33 PM

Author Topic: MPG problem  (Read 3167 times)

0 Members and 1 Guest are viewing this topic.

MPG problem
« on: April 09, 2007, 11:17:50 AM »
We had Mach 3 working OK for my router mill.  We added a rotary axis, which works OK.  Since adding the rotary, the MPG kicks out an Estop on ANY axis on the very 1st click (of the MPG).  I suppose the settings got messed up somewhere, but I don't have any idea where.  The guy that set-up my machine is really busy and I hate to keep bothering him.  Any ideas what might have happened?

Thanks,

Nick, who is just starting to get familiar with Mach 3.  ;)

2 xml files are attached.  "Mach3mill.xml after"is the set-up that kicks out the Estop on MPG movement.  The other one, "Mach3Mill before.xml" is before the rotary was added.

Hood

*
Re: MPG problem
« Reply #1 on: April 09, 2007, 01:46:12 PM »
You first xml has the MPG on pins 4 and 5 of the 2nd port, the new xml has them on pins 13 and 15.
Also you have encoder 1 enabled and encoder 4 disabled in the 1st xml but in the second you have 1 disabled and 4 enabled.
 If you have not changed pins around you might want to try setting up like in the first xml, ie like below

Hood
« Last Edit: April 09, 2007, 01:49:17 PM by Hood »
Re: MPG problem
« Reply #2 on: April 09, 2007, 04:37:08 PM »
Thanks for your time, Hood.  I tried your suggestion, but it's still the same.  Read on... :-[

I should have done this before, but I just now reloaded the "before" xml... and it wont run the MPG either!  :( It worked before the indexer was hooked up.  Ugh, the mud gets deeper...

As for that Encoder 1 being "unchecked", that thing unchecks its self all the time!  ???

Any further directions welcome.

Thanks,

Nick

Hood

*
Re: MPG problem
« Reply #3 on: April 09, 2007, 04:48:20 PM »
Have a look at your outputs, you seem to have quite a few enabled that possibly shouldnt be. Output 1 is set to Port2 Pin3 and that is waht you have the encoder set to and on your second card you have 2-9 as inputs. Outputs 2 and 3 dont have a port set but maybe should be disabled if you are not using them.
Hood

Hood

*
Re: MPG problem
« Reply #4 on: April 09, 2007, 04:56:54 PM »
Also a load of other outputs that are enabled but no ports set, probably shouldnt be enabled or are you using Modbus?
Hood
Re: MPG problem
« Reply #5 on: April 13, 2007, 01:20:53 PM »
Problem resolved... once I ran across the schematic for the encoder board.

Turns out that the MPG was wired into a lug on the encoder board that is pin 10... also, the Estop is port 2 pin 10 (but a different lug).  We had to move the mpg wire to a different lug on the board (making the mpg port 2, pins 12 & 13).  I just cant fathom how it was working before... and to complicate things, I dont think the 'before' xml I posted was the right one.

anyway, thanks for the help.  ahhhh, to be the guniea pig for a prototype set-up.  ::) ;) 8)