Hello Guest it is August 21, 2019, 10:30:40 AM

Author Topic: Random E-stops, urgent!  (Read 2510 times)

0 Members and 1 Guest are viewing this topic.

Random E-stops, urgent!
« on: January 20, 2015, 01:28:58 PM »
Hi!

I've got a 2nd gen joes machine, 4x4 bed, R&P, NEMA23, G540, 48V 12.5A PS,Ethernet smooth stepper, a computer that's plenty fast, and I'm running Mach3..

My problem is random e-stops. I've been fighting this problem for a while and some fixes seem to help but it's gotten worse and my machine is unusable.  The now machine will be running along happily and then Mach3 will perform/detect an E-stop in the middle of the cut, and occasionally when it's just sitting still with the drives on. It's so random I haven't been able to fix it though super systematic troubleshooting so now I'm just replacing parts that I think might be involved and praying something works.

Thus far I've replaced:

Router motor, steppers, motor cable, G540. I was using a parallel port interface and switched to the Ethernet Smooth Stepper. I formatted my computer and reinstalled XP and the latest version of Mach3.  I replaced the 4-year old router thinking that the brushes might be worn and causing an issue with noise. I've tried air cutting and cutting material. I've changed all the settings in mach that I thought might have an effect. There have been instances where it will e-stop when sitting idle, but these are rare.

The only things I haven't physically replaced are the 48V supply to the drive and it's huge cap. The PS seems like a red herring to me in my limited expertise. With such a huge cap it should be pretty immune to voltage drop and my multimeter readings seem to confirm it (+-200mV max). Agree? I'm using a multimeter and not a scope though.
I'm out of ideas and out of money to keep throwing at it. Does anyone have any other ideas?

Thanks,

John
Re: Random E-stops, urgent!
« Reply #1 on: January 20, 2015, 01:56:41 PM »


  ................some fixes seem to help but it's gotten worse and my machine is unusable.  

 
 I've changed all the settings in mach that I thought might have an effect. 
 
Did you set the Debounce to 1000 or more ?
Russ
Re: Random E-stops, urgent!
« Reply #2 on: January 20, 2015, 02:11:37 PM »
Yes, the debounce is at 2000

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Random E-stops, urgent!
« Reply #3 on: January 20, 2015, 03:07:57 PM »
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!