Hello Guest it is November 15, 2019, 05:20:03 AM

Author Topic: Mach3, USB SmoothStepper, Vista Business 32bit , not playing together nicely....  (Read 5808 times)

0 Members and 1 Guest are viewing this topic.

setup new topic rather than hijacking the other thread I posted in...........

Hi folks, looking for some guidance here please. I am building my first mach3 based system and hit a bit of a snag. I have a small HP dc7800 desktop running Vista Business 32bit, with latest Mach3 downloaded (Jan 2015) and the latest USB smoothStepper drivers and m3p loaded from Warp9 site (Jan 2015) so all up to date. I followed the installation instructions and all seemed to go well. I have added the Vista registry tweak from MachSupport also.

I have assigned basic pin outs and an emulated estop, so I could run some test gcode through, At this stage my BOB is connected to the SmoothStepper but no BOB connections to the Granite Servo Drives yet.

So, after releasing estop, I try and jog the machine with arrow keys, or run basic gcode file through and at a glance nothing happens. No DRO movements on the MACH3 screen and n o BOB led modulation indicating step/dir pulses...... no indication of anything happening. When I run the SmoothStepper plugin debugging screen I can see some x y z activity.

I've tried 2 versions of the usb drivers and the m3p plugin, no difference.
SmoothStepperUSBDriver2.08.30.zip
SmoothStepperUSBDriver2.08.14.zip
and
2014-01-04 PlugIn: SmoothStepper_v17fe.zip
2013-04-03 PlugIn: SmoothStepper_v17fd.zip

So its like the SmoothStepper is half working behind the scenes its getting commanded to do movements, but MACH is not displaying the movements on DRO and in the end the smoothstepper diagnostic activity I do see does not actually translate into pin pulses!!!!! I'll flesh this out more tonight when I get home and put up some more detailed info. In the mean time if anyone has a cunning idea I'd appreciate the help!

cheers
is the mach in offline mode? 
Not sure what offline mode is but I'll look and try it! Thanks, Richard
take that back, it shouldn't affect anything.  Maybe you have to attach the terminals for error and reset on each axis?   
FIXED!!!! Thanks to Jeff Birt the answer was straight forward, I had emulated estop whereas I should have used the actual pin and set it to active low. It immediately burst into life and now I am testing gcode through the controller. No the hard part, building the machine!!!!! cheers, Rich