Hello Guest it is April 20, 2019, 01:01:47 PM

Author Topic: New to mach3 and cnc/ not cutting in cm  (Read 2897 times)

0 Members and 1 Guest are viewing this topic.

New to mach3 and cnc/ not cutting in cm
« on: January 04, 2015, 11:06:43 PM »
I have a 3axis cnc with mach 3  and Routcad software. But every time I draw something in cm in the Routcad then load the gcode in mach3 it starts to cut in a larger  scale.  I've checked everything I know of and it's all showing metric. Any help would be great
Re: New to mach3 and cnc/ not cutting in cm
« Reply #1 on: January 05, 2015, 12:04:15 AM »
Change your units to mm.
Re: New to mach3 and cnc/ not cutting in cm
« Reply #2 on: January 05, 2015, 10:41:50 AM »
Thanks for the reply, when I set up the machine w mach I used the mm , and when I go through mach and look around. The mm button is on.
So according to mach it's in mm.  My Routcad software uses cm . . Not sure what els to try.
Tom

Offline RICH

*
  • *
  •  7,313 7,313
    • View Profile
Re: New to mach3 and cnc/ not cutting in cm
« Reply #3 on: January 05, 2015, 12:16:43 PM »
Consult your Routcad manual. I would assume that you can select different units.
If MM is not available you could generate code in inches and use a converter to convert the code to MM.
You could also scale in Mach, have a look in the Mach manual for info.
BTW....never heard of Routcad  ???

RICH
Re: New to mach3 and cnc/ not cutting in cm
« Reply #4 on: January 05, 2015, 09:49:10 PM »
Well I changed my steps from 640 to 320  and now it cuts perfect mm . But now when I'm cutting  a program  it seems to cut the holes good but then when it's time to cut out the object it starts half way up the material. 

Offline RICH

*
  • *
  •  7,313 7,313
    • View Profile
Re: New to mach3 and cnc/ not cutting in cm
« Reply #5 on: January 06, 2015, 07:11:17 AM »
Quote
when it's time to cut out the object it starts half way up the material.
 

You need to define how you want to machine something in CAM.  Know nothing about your software.


RICH
Re: New to mach3 and cnc/ not cutting in cm
« Reply #6 on: January 06, 2015, 06:01:17 PM »
I have a similar problem; I am configured in inches. the X & Y cut fine, but the Z cuts in mm's.

Offline RICH

*
  • *
  •  7,313 7,313
    • View Profile
Re: New to mach3 and cnc/ not cutting in cm
« Reply #7 on: January 06, 2015, 08:16:43 PM »
mikesbeehives,
If the code is correctly generated in inches only, ie; no code to change the z , and the axis steps are correct for inches , and Mach config units are inches and no scaling, then Mach will generate the correct pulses for the move.
Maybe it's your external device or plug-in that is goofy. ???

RICH
Re: New to mach3 and cnc/ not cutting in cm
« Reply #8 on: January 06, 2015, 08:31:36 PM »
If I zero everything after jogging to a max and then jog to the opposite Max., the x & Y dro are correct. The z dro is 54.2, when it has actually only moved 4".