Hello Guest it is October 20, 2019, 10:35:42 AM

Author Topic: Steppers will not reverse  (Read 3350 times)

0 Members and 1 Guest are viewing this topic.

Steppers will not reverse
« on: December 24, 2014, 04:22:20 AM »
Hello all,, let me begin by stating that I am quite fresh to Mach 3 having just purchased the full licence tonight. I am nearing completion of my 4 x 8 router and cannot get the steppers to reverse in the MPG screen. I have searched the web,youtube etc with no results. Both keys + and - on the vitual handpeice spin the steppers in the same direction on all three axis. I am running Leadshine encoders and the steppers rotate in both directions when in test mode. I cannot get any support from the company that I purchased it at the moment due to the time of year. I have also been through the pin menu a dozen times and I'm at my wits end. Sorry for the first post request, however I intend on doing an intro later with a few pics. All the best, thanks in advance and MERRY CHRISTMAS!!!!!!
Regards Carl

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Steppers will not reverse
« Reply #1 on: December 24, 2014, 09:30:53 AM »
Measure the voltage on the direction pins at the drive when trying to move in both directions. In one direction, you should be seeing 0V. In the other direction, you should see 5V.
This issue seems to be more common with newer PC's, some of which seems to have weak parallel ports, or lower voltages.

One thing that works for some is to increase the pulse width in motor tuning to 10-15.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Steppers will not reverse
« Reply #2 on: December 25, 2014, 10:14:37 PM »
Gerry
I have tried your suggestion and the voltages are what you said they should be. I also adjusted the pulse width too, with no results. Back to google and pulling my hair out.
I forgot to mention that I am using an older computer with XP if thats of any help
Regards Carl
« Last Edit: December 25, 2014, 10:20:27 PM by carlossa74 »
Re: Steppers will not reverse
« Reply #3 on: December 27, 2014, 10:31:52 AM »
Hi Carl not sure if this help, I have the same stepper drives and run them on XP, they have been fine except occasionally my X axis refuses to go minus, every time I press minus it went plus, I check the signal at the stepper drive plug and it was correct however no movement. After several attempts I tracked it down to a bad connection on the plug into the stepper, I had nipped the wire on the insulation round the wire so occasionally the signal never connected. I realise the chances of this on all 3 steppers is remote but check your connections, even onto the BOB.  Just another suggestion have you got the drives earthed, I'm sure when I set up my drives some 4 years ago I had an earth-ing problem but cannot remember if it affected the steppers.
Jim
Re: Steppers will not reverse
« Reply #4 on: December 27, 2014, 04:52:54 PM »
Jim
I have re wired everything and checked again. Interesting that you mentioned about the earthing as the DIR- post has nothing mentioned in the company diagram of which I have followed except for the slave axis. Is this the key to my solution? I have attached a diagram, not sure if it will work. I'm not forum/PDF savvy.
Regards Carl
Re: Steppers will not reverse
« Reply #5 on: December 28, 2014, 02:11:33 AM »
OK Carl, first thing to say is I'm no electronics engineer. I looked at the wiring diagram and compared it to my home built system using similar components, it makes sense to me. So I put in the component parts serial numbers in Google and came up with this site https://oceancontrols.com.au/LSK-001.html. I take it you have looked at all the diagrams and setup instructions on the site. However I did find one thing the SMC-223 motor tuning cable you have with the kit is no longer available and removed from the site. This is interesting and worth asking them about this cable as if there is a problem with this cable it could be the source of your problem.
Good luck mate.
Jim
Re: Steppers will not reverse
« Reply #6 on: December 28, 2014, 02:58:37 AM »
Jim
The drives come pre tuned and I think they sent that cable in the kit. That is the company I purchased everything from and hopefully will be open tomorrow for some support.
Thanks for looking
Regards Carl

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Steppers will not reverse
« Reply #7 on: December 28, 2014, 05:42:54 AM »
Hi,

i am not sure, but in your wiring diagram Dir- is not connected for
X Y and Z axis. only for the A-axis is a link between Pul- and Dir-

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Steppers will not reverse
« Reply #8 on: December 29, 2014, 05:50:56 AM »
Ok, Its now alive. Thanks to all that contributed. As stated the DIR- wasn't connected so I bridged it with PUL- and I'm now in business. Its a pity the wiring schematic didn't show it and I didn't notice the slave axis as Im not using it. Some finishing touches through the week and I should be making dust by the weekend..........................Hopefully.
Thanks again
Carl