Hello Guest it is October 22, 2019, 05:39:50 AM

Author Topic: Opening tool screen from NF  (Read 7021 times)

0 Members and 1 Guest are viewing this topic.

Opening tool screen from NF
« on: December 03, 2014, 11:37:34 PM »
Hi Ron:

First I would like to thank you for a superb little program. I use it every day in my work. It is the best money I ever spent in my many
years in CNC machining.

My question is the drop down screen, of the Tool Table, from within the NF program. It works just fine in the standard Mach3 srcreen,
but does not work in the 2010 screen set. I set-up a new Win 7 mini computer with a new SSD. I thought the Tool Table worked
when I first ran the program with the 2010 set, but after more stuff was installed, it does not open the T-Table anymore. Do you know of any conflicts or what can be done? Would a complete removal of Mach3, and then a re-install of Mach3, and NF do it?

Thanks,

John

Re: Opening tool screen from NF
« Reply #1 on: December 04, 2014, 07:17:26 AM »
I am not sure I understand what tool table drop down you are referring to. Can you show me a screen shot of the tool table open with the wizards?

Rarely does re-installing Mach or the wizards improve anything- if you have some strange condition it is probably saved in the ini file and will still be there, unless of course you build a whole new ini.
Re: Opening tool screen from NF
« Reply #2 on: December 06, 2014, 02:14:43 PM »
Hello Ron:

I tried (3) times to send and attachement, and kept getting messages that it was a duplicte name, or it did not accept that file type, or that I had already had a file with that name in the system. Kind of frustrating.

However, I will write the exact sequence I am talking about since the visual picture is not happening.

1. Select "Newfangled" from the Wizards menu.
2. Material Selection screen opens.
    select material from list, and click [Continue] box.
3. Please Choose an Operation screen opens.
    make operation choice from 15 available operations listed with graphic pictures.
4 Tool Properties screen opens.
   Top center of page is a button; [Select Tool from Table]
5. Click on button.
6. Window pops open on screen with the heading;
   [Select Tool from Tool Table]
   All the tools in your Tool Table are in this window.
7. Click on a Tool.
8 The tool # is automatically entered into the Tool# black entry box, and the tool diameter is automatically entered into the
   black entry box labeled [Tool dia]
9. Click on the OK in lower right corner of [Select Tool from Tool Table] box, and window disappears.
10 You can now enter other selections, i.e., spindle RPM, Feed Rate etc.
11. Click green [Continue] box at lower right corner of screen.
12 The data entry screen opens, for X,Y coordinates, CW, CCW, Inch, Metric ets.
    This is the last screen and the Post code, Preview choices are in boxes.

The [Select Tool from Table] window is what I am asking about.
That pop-open window does not work on the 2010 screen set. Perhaps it is because in the 2010 screen set, he has an Icon
at the top of the page, specifically for opening the Newfangled wizards, and something gets lost in the mix.

Thanks

John


Re: Opening tool screen from NF
« Reply #3 on: December 06, 2014, 04:48:06 PM »
Ok, thanks for the detailed description, now I understand the sequence. I do not understand how this is happening. When a wizard is loaded it is exactly like loading a new screen set. The old set- 2010 in this case- goes away and the wizard set is loaded in its place.

You say "That pop-open window does not work on the 2010 screen set. " What do you mean? Does the window open Ok? Does it fail to use your selection? Is it not filled with the tool data?

How about the Material window in the first screen, does that open and work with 2010? I am asking because that window works exactly the same inside the program, it just has different data in it.
Re: Opening tool screen from NF
« Reply #4 on: December 06, 2014, 06:35:57 PM »
Hi Ron:

The complete Newfanled wizard works great. It is just that Tool Table window that doesn't open. So, I always have to write down the tool# before I use the   Wizard. That window opening up makes the job slick, but so far only on the stardard Mach3 screen set.
When I click on the button to open the Tool Table, nothing happens. It is as if I never clicked on the button.
So, in order to put the Tool# and diameter in the two black data boxes, it is necessary to click on the box, ,  and manually enter the Tool#, and Diameter.
I have minimized the screen set to see if the Tool Table window was hiding behind it, but there is nothing there. If just does not open up.


John

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Opening tool screen from NF
« Reply #5 on: December 06, 2014, 08:27:08 PM »
AS a reference it works fine here. The tool selection box opens every time.

Might want to try downloading a NEW copy of the NFW.

Just a thought, (;-) TP
Re: Opening tool screen from NF
« Reply #6 on: December 06, 2014, 10:46:00 PM »
Thanks TP:
I will try that.


John
Re: Opening tool screen from NF
« Reply #7 on: December 06, 2014, 11:33:44 PM »
TP:

No change.



Re: Opening tool screen from NF
« Reply #8 on: December 06, 2014, 11:46:43 PM »
TP:

I did a screen load of the standard Mach3Mill, with the 2010-4 screen set. I did not change the xml file from the working 2010 screen I have been using. It has the original xml from the Mach3Mill. I ran the NF wizard, and the Tool Table does open like it should.
I will hand load item by item the NewFile I just created and try it again.

I cannot do it now, but will report back tomorrow.

Maybe my working screen-set has a bug in the xml. I am encouraged with this latest development.

John



Re: Opening tool screen from NF
« Reply #9 on: December 07, 2014, 12:59:27 PM »
The latest 2010 screen does work properly with the NF Wizard, and the Tool Table window opens up, and works. The screen set that did not allow the Tool Table to function had one difference- It had been modified with background colors using MachScreen. I am now of the opinion that the color modifications  was the culprit. When I loaded the Standard Mach3 screen with the 2010 screen, everything worked in NF Wizards.

 When I loaded the XML file from the older, 2010 set with all the motor setting,i/o dat, to make it run, the NF Tool Table window stopped working. The XML also contained the Color settings I had created with Machscreen.

I have not tried implementing colors with Machscreen yet, to prove my assumption.

If anybody understands the process of modifying the color background, and could explain what goes on, I would like to hear.

Thanks

John