Hello Guest it is October 16, 2019, 11:46:38 PM

Author Topic: Reverse Run and 'Radius to end of arc differs from radius to start' problems  (Read 8873 times)

0 Members and 1 Guest are viewing this topic.

I'm trying to resolve two issues with Mach3. I'm using it for plasma with THC300 using SheetCam but seem to have the same problem using Gcode samples.

'Radius to end of arc differs from radius to start' error occurs on Version   but not versions   can anyone help with this?

I haven't been able to get the 'Reverse Run' button to work. It either does nothing or gives error message: Cannot find recovery points. Solution too complex, or Nothing to freehold.

rayhager7

Sorry forgot to detail versions... the radius error occurs on versions 2.00.057 and 2.00.061 but not on 1.84.002 or 2.00.047. I haven't been able to get the Reverse Run button to work on any version.

rayhager7

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Rayhager,
    Could you post the code that is giving you the error message. You may need to tweak your post processor for sheet cam. Myself or someone else here may be able to help you with that.
   As far as the reverse run, have you tried it like this? Load a program, run for a bit until you get to a point you want to reverse the run. Press feedhold, cycle stop, reverse run, cycle start. I will try this on my machine in a bit.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Here are a couple posts I've been working with.

Yes, I've tried various sequences for reverse run but the button toggle light doesn't come on....  :(

Ray

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Hey Ray, I tried to load the code and got the same error message as you. Post the dxf and I will try to generate the code and see how it does.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Brett.

Here are a couple of the .dxf files.

Thanks for helping with this.
Ray

Offline Chaoticone

*
  • *
  •  5,607 5,607
  • Precision Chaos
    • View Profile
Seems to be your code. I generated this and it loads fine. Reverse run works as well. It looks like you may need to tweak your post processor.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Check your license file.. do you see Demo mode? If so you need to register the software to get that function.
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Thanks for the feedback.

I also posted this on the sheetcam forum and Les provided a modified post processor that took care of the problem.

Ray