Hello Guest it is December 11, 2019, 03:11:06 AM

Author Topic: Strange X axis distance travel at higher Feedrate % ; (  (Read 4355 times)

0 Members and 1 Guest are viewing this topic.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Strange X axis distance travel at higher Feedrate % ; (
« on: November 22, 2014, 06:03:26 AM »
Hi!
I´ve come onto a problem that  as a relative beginner has me baffled ; (.
I´m milling polistrirene foam, quite quickly, on a home built machine thats X axis is 13 feet long,  Y axis 2 feet 4 inches and  Z 35 inches. (4000mm x 2000mm x 900mm aprox).
I´m using Easy Steppers, by Leadshine, NEMA 34, ES_MH33480, which give 8Nm,with encoders,  driven by ES DH 2306 Hybrid Servo Drivers.An economical alternative to servos.
I tend to give feed rates of 12000mm per minute in DESKPROTO, the software that generates the g codes. I then vary the feed rate in the MACH3 screen, depending on the area being milled, often way above 100%.
I´ve discovered that if  I speed up above a certain rate, much lower than the machine is capable of delivering, the distance travelled in both X and Y axis is not accurate ; (. But the machine does not loose steps nor position (due to the encoders) as I can G0 X0 Y0 Z0 and it goes back perfectly to the work piece zero point.
If I then decrease % speed, again on the MACH screen, it reverts to correct travel, and milles the piece with the desired form.
 I´ve yet to try changing to another computer, it has XP installed.
If I manually instruct for example, G0 x 2000mm, it goes perfectly there, even though the speed percentage is quite high. G 0 X 0 and it come back perfectly.
Anyone any ideas?
I made a short video, I´ll try and post it.
Thanks in advance,
Frank.
www.franknorton.com
PS This is a second attenpt to upload this Post, hope I´m not repeating it; )

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #1 on: November 22, 2014, 06:27:55 AM »
There are known issues in Mach3 when using feedrate override well over 100%.
It's recommended to program at the maximum feedrate you may use, and use FRO to lower the speed only.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #2 on: November 22, 2014, 09:36:37 AM »
Many thanks Gerry, I will try that straight away!
Frank.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #3 on: December 15, 2014, 08:27:48 AM »
Dear Ger,
I tried various approaches; not changing feed rate in percentage FRO window, or only lowering it below 100%, , and to no avail. I´ve since tweaked the Drivers, and it mills fine at 9000mm (and probably quicker) but only in straight lines.
When I load an stl file of, for example,  a human face, then it suddenly slows as if the calcs for a "3D" object were too complex to do quickly. Mysterious....
I´m currently doing tests, and hope to publish another post with additional data to see if anyone can throw some more light on the subject.
Many thanks for your input!

Frank.

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #4 on: December 15, 2014, 09:25:12 AM »
Quote
When I load an stl file of, for example,  a human face, then it suddenly slows as if the calcs for a "3D" object were too complex to do quickly. Mysterious....

Turn off the toolpath display when doing 3D toolpaths, and it should work much better. Mach3's toolpath display uses a lot or resources. Your PC may not be able to handle it very well.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #5 on: December 15, 2014, 11:04:53 AM »
Hi Ger,
Tried that, (turned off Tool Display in Diagnostics) but no noticeable improvement.
It seems I´m up against using either Constant Velocity mode for  fast but very inaccurate 3D milling at 9000mm, a speed which polystyrene foam allows, or Exact Stop mode for fast straight-line milling (very little of this in  in 3D milling), followed by painfully slow reliefs.
Having built a machine capable of these speeds, its now extremely frustrating to think I wont be able to use it at these speeds with MACH..; (
Are there other Mach configs..…..kernel speed, “CV Dist tolerance”, “Stop CV on angles”, “G100 adaptative NurbsCV”.... or even pc processor speed or RAM,  that influence such speeds?
My pc is Windows XP, 2.8GHz processor, with 2.0GB RAM.
Would MACH 4 be a solution?
Thanks again,
Frank.




Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #6 on: December 15, 2014, 11:17:19 AM »
Turn off all CV options, both in General Config and the Settings page, and see what it does (With CV mode on). Generally, the only CV setting you need to use is "Stop CV on Angles".
But try to avoid exceeding 100% FRO.


Quote
I´ve discovered that if  I speed up above a certain rate, much lower than the machine is capable of delivering, the distance travelled in both X and Y axis is not accurate ; (. But the machine does not loose steps nor position (due to the encoders) as I can G0 X0 Y0 Z0 and it goes back perfectly to the work piece zero point.

This certainly sounds like either an issue with your drives, or a mechanical issue.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #7 on: December 15, 2014, 12:29:51 PM »
Hi Ger,

when you say Turn off all CV options, on the Settings Page, what CV options are there? Please see pdf "Settings Page"  attached.

As far as a possible drivers or mechanical problem, that was November 22, I´ve since tweaked them , and to test to see if they´re ok, I´ve loaded a short routine (see attached "Test File") at 12000mm/min feedrate, it does it perfectly, and Homes back on Material Zero perfectly (No steps lost, right?) . If I change the G61 to G64 (Exact Stop off, Constant Velocity On, yeah?) it cuts the pocket way short of the 600mm indicated, about 580mm.

I am about to try your suggestion of all CV settings off in General Config, with CV mode on. Will not exceed 100%, that value I am not changing since you advised.
Thanks,
Frank

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #8 on: December 15, 2014, 01:26:54 PM »
CV Distance and CV Feedrate, which appear to be already off.


Quote
If I change the G61 to G64 (Exact Stop off, Constant Velocity On, yeah?) it cuts the pocket way short of the 600mm indicated, about 580mm.

This sounds like it's because your acceleration is too low, and CV mode is rounding the corners. If you wan to be able to cut at high feedrates, then you NEED high acceleration rates to avoid issues with CV mode. sometimes you can minimize this issue with "Stop CV on Angles".
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Re: Strange X axis distance travel at higher Feedrate % ; (
« Reply #9 on: December 16, 2014, 08:01:10 AM »
Problem solved!
Thanks Ger, I increased the acceleration values, from 200 to 600, in Motor Tuning, and it now runs fast as hell ; - )
Above 9000mm/minute, design faults manisfest themselves: a not very rigid Z axis, flexes with such brusque movements of the Y axis, causing sloppy milling detail. But that will be another chapter in this build.
Many thanks for being there,
Regards,
Frank.
Attached a photo of a Buddha head milled using MACH3 in conjuntion with DESKPROTO for gcodes.