Hello Guest it is May 09, 2021, 07:41:39 PM

Author Topic: ModIO and Mach not keeping up with MPG  (Read 6495 times)

0 Members and 1 Guest are viewing this topic.

ModIO and Mach not keeping up with MPG
« on: April 02, 2007, 09:47:28 AM »
I have hooked up my ModIO and wired the MPG. The MPG works
fine if you turn the handle really slow, about 1 click per second
max, in single step mode. If you spin the MPG at about 10 clicks
or so per second, nothing happens. The Mach DRO's don't even
display a change of position.

The ModIO LCD displays a count from the MPG in the
upper right hand corner. This count is in hexadecimal with 4 counts
per click of the MPG and it is accurate no matter how fast you
turn the MPG handle.

So it seems that the ModIO is counting just fine but not able to
transfer the data to Mach unless you turn the MPG really slow.

I messed with settings for 2 hours and just can't figure it out.
I read through the ModIO manual thoroughly and made sure my settings
were just as pictured in the manual.

Any ideas?

Scott

Here are some screen shots showing my settings. 








Re: ModIO and Mach not keeping up with MPG
« Reply #1 on: April 02, 2007, 10:47:41 PM »
Scott,

This is just a shot in the dark... I notice your serial port is Com5. It's my experience that port numbers greater than 4 are from addon devices, like maybe a USB serial adapter. Do you have any system serial ports on the motherboard that are in the Com1-Com4 range? Say with an IRQ of 3 or 4 and an I/O of 03F8 or 03E8?

Again, just a thought. Someone more knowledgable will probably have a better suggestion.

David

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Re: ModIO and Mach not keeping up with MPG
« Reply #2 on: April 02, 2007, 11:12:29 PM »
Try changing from single step to step/velocity mode on your tab (MPG) screen and see if that helps.


Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: ModIO and Mach not keeping up with MPG
« Reply #3 on: April 03, 2007, 06:05:35 AM »
I got it.
Apparantly Mach will not work with an MPG when set in the single step
mode.  I set it to multistep and then adjusted the counts for the MPG in
the Ports and Pins screen to 4. 
Single step mode works just fine with the keyboard, just not the MPG.
I did not want to use a velocity mode as this is just not how I want to
use my MPG.  It is used for final fine positioning.  But yes, it did work
in velocity mode.

thanks,
Scott

Offline chl

*
  •  13 13
    • View Profile
Re: ModIO and Mach not keeping up with MPG
« Reply #4 on: April 03, 2007, 01:58:10 PM »
Hi my mpg hooked to my modio work fine in single step.......it just do 1 step for every spin on the mpg or click.....you must stop the mpg for every step..... it just what it should do in step mode :)
« Last Edit: April 03, 2007, 02:02:52 PM by chl »