Hello Guest it is July 22, 2019, 06:24:40 AM

Author Topic: Mach3 Turn won't give spindle feedback.  (Read 6150 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Turn won't give spindle feedback.
« on: November 13, 2014, 11:14:23 PM »
Hope someone can help!

I get an error message "Simulating feeds, no spindle feedback"

I have a spindle sensor and it correctly displays the RPM on the Mach Screen and I can simulate the thread travel (not accurately without feedback).

I read somewhere that I needed to enable the checkbox "Use Spindle Feedback in Sync Modes", but all that does is turn on "continuously" the green "Feedback" Light, and causes the tool to refuses moving from the thread position. What am I missing?

I'm using the latest Mach3 version .066

Ray

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn won't give spindle feedback.
« Reply #1 on: November 14, 2014, 03:20:59 AM »
If you attach your xml I will ave a look through your settings and maybe find the problem.

Hood
Re: Mach3 Turn won't give spindle feedback.
« Reply #2 on: November 14, 2014, 12:47:07 PM »
Hood,

Thanks for the response... Here is the XML

Ray

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn won't give spindle feedback.
« Reply #3 on: November 14, 2014, 12:52:35 PM »
You dont have the Index enabled and the Pin number for it set up.
You will also need Use Spindle Feedback in Sync Mode chosen.
Hood
Re: Mach3 Turn won't give spindle feedback.
« Reply #4 on: November 14, 2014, 01:22:08 PM »
Hood,

When I turn on the Use Spindle Feedback in Sync Mode the green light stay on continuously, and the tool refuses to move from the thread start position (obviously waiting for a signal). I'm using a USB RPM sensor which Mach3 reads... what port and pin would I enable for that?

Thanks,
Ray

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn won't give spindle feedback.
« Reply #5 on: November 14, 2014, 01:24:11 PM »
I have never seen or heard of a USB speed sensor for Mach, have you got some info on it?
Hood
Re: Mach3 Turn won't give spindle feedback.
« Reply #6 on: November 14, 2014, 01:29:32 PM »

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn won't give spindle feedback.
« Reply #7 on: November 14, 2014, 01:30:38 PM »
Ok I looked in your xml and I see the plugin for the tach and looked at Vista CNC site.
What I am thinking is that may not work because the Index signal will most likely need to be via the ESS as it is that that does the threading.
Hood
Re: Mach3 Turn won't give spindle feedback.
« Reply #8 on: November 14, 2014, 01:34:02 PM »
Hood,

So what is my alternative? What simple alternative do I need to get it working?

Ray

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 Turn won't give spindle feedback.
« Reply #9 on: November 14, 2014, 01:38:25 PM »
A simple alternative is a slotted disc and an optical sensor, I used to use Optek OPB916B sensors and the only other thing required was the limiting resistor for the LED, think 220Ohm was what I used.
Another option is an encoder. The ESS can easily read the Index from an encoder and that can easily be hooked up to the ESS.
It may be possible to hook up your current sensor direct to the ESS but obviously that would require you hacking into the cable, so best check with Vista first to make sure it is possible.


Hood