Author Topic: Circles not coming out round...  (Read 1544 times)

0 Members and 1 Guest are viewing this topic.

Offline HamUK

  • Holding
  • Posts: 2
    • View Profile
Circles not coming out round...
« on: October 28, 2014, 07:18:08 PM »
Hi All,

I've been using Mach3 for about 6 months now on my CNC converted mill, I seem to be having problems with my latest part getting it to produce round holes though. Here's a snipped of code I'm running:

Code: [Select]
G71
S2100 M03
G01 G43 X34 Y-25 Z2 F800 H12
Z-11.5 F174.4
X31.5
G03 X31.5 Y-25 I2.5 J0
G01 X34
Z2 F800
M30

I'm using a Ø10mm cutter, which should give a hole diameter of Ø15mm. Cutting and measuring a hole however, I get ~14.7mm in the Y direction, and ~14.3mm in the X direction. That latter value seems too far under to be just a backlash issue (I've measured backlash to be about 0.06mm in both axes, which I've tuned out with backlash compensation), I'm suspecting something's up with my Mach3 setup. Any ideas?

Thanks for any help.

Offline handsmfg

  • Active Member
  • Posts: 65
    • View Profile
Re: Circles not coming out round...
« Reply #1 on: October 29, 2014, 11:46:05 AM »
I wouldn't rule out backlash until you check it with an indicator. I had a jam nut come loose in a hard to see location and that blew my no backlash theory right out of the water.

Eric

Offline Hood

  • Mach4 Alpha
  • Posts: 25,775
  • Carnoustie, Scotland
    • View Profile
Re: Circles not coming out round...
« Reply #2 on: October 29, 2014, 02:27:47 PM »
Disable backlash comp, restart Mach and see how things are.
Hood

Offline HamUK

  • Holding
  • Posts: 2
    • View Profile
Re: Circles not coming out round...
« Reply #3 on: October 29, 2014, 03:55:05 PM »
Ok I worked it out, it wasn't backlash but just flex in the machine. I suspect I was work hardening the material so I put in a new cutter, reduced the DOC and cranked up the feed rate and the holes magically started coming out round again. Perhaps I'm being a bit too ambitious with my little mill :) Thanks for the help!