Hello Guest it is May 22, 2019, 05:29:12 PM

Author Topic: Gecko G540, the A axis only moves into single direction  (Read 1649 times)

0 Members and 1 Guest are viewing this topic.

Gecko G540, the A axis only moves into single direction
« on: October 20, 2014, 02:03:32 PM »
The A axis only moves into single direction.
I've attached my settings bellow, when i connect the same motor to any other axis X, Y ,Z it does move into both dirrections as it should.
I've never used this axes before on this controller so i'm not sure if it ever worked.
I have 2 keys set to move the A axis, "z" keyboard key and "x" keyboard key, and when i press any of them the voltage on pins 6-7, 8-9 does change and of course the're set to move the axis into different directions.
I can't figure out what's wrong, is it the controller or i have some wrong settings
Please help, thanks in advance

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Gecko G540, the A axis only moves into single direction
« Reply #1 on: October 24, 2014, 08:46:16 AM »
Do your other axis work?

If so what happens if you swap drivers or steppers from another axis?

What is your motor tuning for the A axis?

Rotational soft limits set on the gen config page?

A axis set to angular?
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Gecko G540, the A axis only moves into single direction
« Reply #2 on: November 01, 2014, 01:16:44 AM »
Easy , just swap out the driver and see what happens. If it persists then swap out the motor and driver together. If it persists it's the BOB. If it gets solved before that it's the last item you changed.

Offline Vogavt

*
  •  258 258
    • View Profile
Re: Gecko G540, the A axis only moves into single direction
« Reply #3 on: November 08, 2014, 02:24:47 PM »
I was thinking the "+" and "-" keys are the defaults for moving the "A-axis".

So you changed them in the system hotkey settings?  

Make sure you aren't duplicating those keys somewhere and confusing Mach3 on how to operate.

Maybe post your xml and we can take a look.
« Last Edit: November 08, 2014, 02:29:19 PM by Vogavt »