Hello Guest it is July 23, 2019, 08:09:31 AM

Author Topic: Mach3 + Galil doesnt stop motor when home switch trigged  (Read 3519 times)

0 Members and 1 Guest are viewing this topic.

Mach3 + Galil doesnt stop motor when home switch trigged
« on: October 17, 2014, 07:35:39 AM »
Hello,

I am using the X- switch as the home switch (I have wired the X- switch to the Home input on the Galil).
I have configured the limit and home switches as active low in the plugin. Port mappings according to the plugin PDF documentation.
When I jog normally, Mach3 stops the motor whenever I hit a limit switch and the limit switch LED lights up in Mach3.
When I try to home X (REF X) however, the home switch and the X- switch both light up and the motor stops. Then nothing, no zeroing, no offsets, nothing. I am also unable to jog unless I hit the Stop button, so I guess the Galil plugin is stuck in the homing routine?

The Galil (using stepper motors) is configured with LDA = 0 and OEA = 0.

I tried it with LDA = 3 (both  limit switches disabled). In this case, when homing the motor just stops forever until it hits a hard stop at which point I pulled the plug on it.

In Mach3-> Ports and Pins, X-, X+ and X Home are not active low or emulated.

Any ideas?

Offline smurph

*
  • *
  •  1,107 1,107
  • "That there... that's an RV."
    • View Profile
Re: Mach3 + Galil doesnt stop motor when home switch trigged
« Reply #1 on: October 19, 2014, 02:39:53 PM »
The way the home and limits are wired will change the way the switch is sensed internally.  LSCOM + or - makes this happen.  Try inverting the limits and homes active low in the plugin configuration.  (It is actually setting the CN command).  This is always a pain to get right.  You need to have an understanding of how the Galil works to get it right.  I still get it confused and I have set up so many Galil I can't remember them all! 

Steve
Re: Mach3 + Galil doesnt stop motor when home switch trigged
« Reply #2 on: October 20, 2014, 06:03:01 AM »
Hi Steve and thanks for your reply. I have LSCOM connected to +5 V. With CN 1,1 and MTA=-2 I can use Galil tools and the limit switches light up correctly (green when not triggered, when I hit the forward one it turns red). The status is also correctly reported by the TS command.

When I check the "active low" setting in the Galil plugin, it also send the correct CN commands according to GalilDebug.txt
If I uncheck this, I can't move at all. The error message is either:

Galil: Can't move toward limit
or
Galil Error: 22 Begin not possible due to limit switch

Depending on which direction I want to move (positive or negative)

I have attached a GalilDebug.txt where the active low checkboxes are set in the plugin settings. When I press Ref X, it moves toward the X+ switch, and then just hangs. I can't do anything unless I press stop. The X++ limit light lights up in Mach3 BTW.
Re: Mach3 + Galil doesnt stop motor when home switch trigged
« Reply #3 on: October 28, 2014, 07:37:52 AM »
I have found a possible bug in the Galil plugin.
If I check the option "Config Galil Limits Active Low", the plugin send the "CN 1," command according to GalilDebug.txt.
The Galil command documentation however, specifies that active low should be "CN -1,".

Any idea why the plugin sends the opposite command?
Re: Mach3 + Galil doesnt stop motor when home switch trigged
« Reply #4 on: October 28, 2014, 10:19:36 AM »
Never mind the above post, I deleted Mach3 including the leftovers files in the C:\Mach3 folder and reinstalled everything. It works now.