Hello Guest it is June 24, 2019, 10:28:30 AM

Author Topic: Spindle requires two inputs for control  (Read 2127 times)

0 Members and 1 Guest are viewing this topic.

Spindle requires two inputs for control
« on: October 14, 2014, 06:09:39 PM »
The inverter controlling my spindle requires two inputs - one switches the spindle (actually the inverter) on/off. The other controls direction. The vendor configured the machine so that CW and CCW both trigger Output#1, which is wired to the on/off inverter input, so at least the spindle turns, but it's always CW (better than the alternative). How do I get the spindle commands (M3, M4, M5) to trigger TWO outputs? One output must respond to spindle direction -these is easily accomplished form the spindle config screen. It's the other one I can't figure out. I need an output to respond to any command turning the spindle on or off. How do I do this?
Thanks.

Offline TPS

*
  •  1,304 1,304
    • View Profile
Re: Spindle requires two inputs for control
« Reply #1 on: October 15, 2014, 04:03:02 AM »
configure
Output#1 for CW
Output#2 for CCW

then connect two relays to the outputs

Relay 1 CW
Relay 2 CCW

Relay 1 one NO contact to ON/OFF
Relay 2 one NO contact to ON/OFF (parallel to Relay 1) and an other NO contact to the direction input.

Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Spindle requires two inputs for control
« Reply #2 on: October 15, 2014, 10:06:41 AM »
I was hoping there was a no-hardware way, perhaps some sort of macro or something that could be configured as an output and in turn trigger other outputs. However, all this turns out not to be necessary. The inverter manual, written in Chinglish, was ambiguous to say the least. It turns out that the FWD only runs the spindle "forward" (CW), in spite of what the manual says. There is another input that can be configured to serve as the REV input. In each case, pulling the input low powers on the inverter, but in the appropriate direction.

In any event, thanks for your advice Thomas.

Offline TPS

*
  •  1,304 1,304
    • View Profile
Re: Spindle requires two inputs for control
« Reply #3 on: October 16, 2014, 04:15:28 AM »
Hi Llaves,

there is also a non hardware way.
go to configuration -> ports and pins -> spindle and disable the relay option.
go to your macro folder depending on your profile you are using

open M3.M1S (CW spindle on)
add:
ActivateSignal(OUTPUT1) ‘ Turn on spindle enable

open M4.M1S (CCW spindle on)
add:
ActivateSignal(OUTPUT1) ‘ Turn on spindle enable
ActivateSignal(OUTPUT2) ‘ Turn on spindle direction

open M5.M1S (spindle off)
add:
DeactivateSignal(OUTPUT1) ‘ Turn off spindle enable
DeactivateSignal(OUTPUT2) ‘ Turn off spindle direction

Regards Thomas
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Spindle requires two inputs for control
« Reply #4 on: October 16, 2014, 12:14:47 PM »
Thanks for this additional info. Clearly I'll need to learn about macros and the capabilities they provide. At the moment I'm trying to get my CNC router running. It came with no instructions other than eight screen-shots of Mach3 setup screens, and three of those were wrong. I'm new to Mach3, so this information is tremendously useful.