Hello Guest it is November 18, 2019, 05:51:38 AM

Author Topic: Huyanyang VFD plugin  (Read 1603 times)

0 Members and 1 Guest are viewing this topic.

Huyanyang VFD plugin
« on: October 11, 2014, 08:56:56 PM »
Hi all
I've been struggling to get my Huyanyang VFD plugin sorted, been reading lots of posts and a lot say different things in the way of setting. Was there or is there a published set of vsd and mach3 setting so I can start from stage 1 and work through systematically.

I use a gecko g540 so if I can't get this plugin to work properly should I just use the gecko to switch the spindle via its output and control the speed via the 0-10v signal?

Maybe there is an update to this.... Can't find many current posts...


Thanks Dave
Re: Huyanyang VFD plugin
« Reply #1 on: October 19, 2014, 06:46:54 PM »
I'm not using any plugin at all.. I've got a 2.2kw spindle and VFD from ebay, and I have my spindle controlled by my G540 PWM ouput. The relay in the VFD controls my air asissted blast gate and on/off control of my dust collector. Take it one step at a time when configuring your VFD and make sure it's still working before moving on to another setting. One problem I had was that someone in one of the many many posts I had read on this VFD had specified a PD setting that caused the spindle to start  up over 10 minutes or so. This meant I was looking for movement on the spindle and it was not happening only because I didn't wait 10 minutes. Took awhile to figure that one out. Basically 3 wires are really all that are needed. Run and PWM and I guess ground would be nice. I think I have a 5-6 wire cable connected to the VFD for control signals.
Re: Huyanyang VFD plugin
« Reply #2 on: January 24, 2016, 06:29:10 AM »
Did you succeed?  I have a similar setup. and having problems with making the motor run.  I have seen reference to the Gecko g540 and the dedicated PWM terminal.   I have a C10 board that has no special pwm pin.  I'm wundering if that is my issue.

sbr.
Re: Huyanyang VFD plugin
« Reply #3 on: January 24, 2016, 07:29:39 PM »
Hi sbr

Yes I did get it to work.... I can't remember exactly what I did though! Had to install a plugin that changed the usb setting or something like that then installed the Huyanyang plug in.
I'm away at work for a few more days, if I remember when I get back i'll fire up that computer and check what was installed.

Once it's working its great. One issue I had was it seems to be sensitive to noise on the cable from the USB adapter to the VSD, need good shielded cable for this.