Hello Guest it is June 05, 2023, 03:17:18 AM

Author Topic: Problem converting from LinuxCNC to Mach3.  (Read 2525 times)

0 Members and 1 Guest are viewing this topic.

Problem converting from LinuxCNC to Mach3.
« on: October 07, 2014, 11:00:39 PM »
First off, this is not going to turn into a this or that session between Linux/Windows/Mach3/LinuxCNC. I am very accomplished Linux System Architect but I just decided i didn't have time to spend becoming a LinuxCNC expert. That is all on that subject, now on to the regularly scheduled program...

I recently purchased Mach3 which I must say i am very impressed with and I can already see it's going to allow me to be MUCH more productive.

My problem is that when I try to do tasks like I used to, in the case cutting 0.75" slots to lock a piece of 0.75" MDF into, the cut is undersized to the tune of about 0.040". This worked perfectly for me on the old system top the point where if I cut a 0.75 slot then a chunk of 0.75 MDF fir nice and snug.

I am using BobCad/Cam for code generation which I did changed the post processor for. The code looks reasonable enough with everything on expected increments for the part (everything is on 1/8 to 1/4 inch increments and the cooridinates reflect that.

I have run the X-Axis calibration tool for steps per inch and it comes out spot on for a 15" travel. The resultant slot./pocket ends up being 0.7010 "ish" instead of 0.75. The bit I am using (same bit as was used under LinuxCNC) is in fact 0.249". I can run the code time and time again on the same stock and get the same results. I've even reslected all of the geometry under BC/CAM and regenerated the tool paths to no avail.

I have also upped the step pulse to'5us as suggested in another thread for g540 controllers.

Any suggestions?
Re: Problem converting from LinuxCNC to Mach3.
« Reply #1 on: October 08, 2014, 01:33:49 AM »
Hi ckovacs:

You might want to give the New Fangled Wizards a try for generating code for simple things like a slot. The wizard takes the tool diameter input in the set-up file, and the tool number for the tool table height offset, and generates simple code, using all G40, no cutter comp codes. Things like slots, circles, hole patterns are super fast, and quick. It will show a tool path preview, and then post the code directly into your tool file screen, ready to go. The Wizards run without exiting Mach3.

To be off by .040" is a huge error. It could be a goofy cutter comp getting into the mix, or an erroneous tool table wear setting.

If you write a simple program by hand,  to cut a square, about .100 deep, like 1.000 X 1.000, with no cutter comp, and measure with calipers, it should cut a 1.250 X 1.250 square.

M6 T1 (.250 cutter)
G43 H1
G0 X0.0 Y0.0 Z.1 M3
G1 Z-.100 F4
X1 Y0.0
G0 Z.1 M5

This will eliminate the machine as a problem. The machine program is telling Mach3 where to drive the cutter, and that is what it is doing. It will cut the shape "exactly wrong" every time, without fail.

Re: Problem converting from LinuxCNC to Mach3.
« Reply #2 on: October 08, 2014, 01:36:24 AM »
John, thanks for the suggestions. I'll try setting up a simple square pocket tomorrow and get back here with the results.

Re: Problem converting from LinuxCNC to Mach3.
« Reply #3 on: October 08, 2014, 09:48:25 PM »
John I ran the code above and it showed me my machine was having problems which I'd overlooked. The technical term for the problem is PEBKAC (problem exists between keyboard and chair).  Among the software change, I did indeed have to adjust a backlash nuts and never got the lead screws tightened properly. Snugged it all up and I am back to making .75 slots. Thanks for your suggestion.

Re: Problem converting from LinuxCNC to Mach3.
« Reply #4 on: October 08, 2014, 09:52:09 PM »
hi ckovacs:

Glad to hear your problem was solved.