Author Topic: Homing Problem - Axis do not consistently back off the switch  (Read 8896 times)

0 Members and 1 Guest are viewing this topic.

Offline go930turbo

  • Active Member
  • Posts: 4
    • View Profile
Homing Problem - Axis do not consistently back off the switch
« on: September 22, 2014, 03:07:17 PM »
I am running Version R3.043.066 of Mach3 with a USB Digital Dream 5-Axis board on a small mill with a moving table.  At this point I am only using the X,Y,Z axis.  I have limit switches at the ++ and -- of each axis, and each of the switches uses a separate Mach3 input.  In >Input Signals< I have assigned the Y-- and X-- switches as Home Switches.  The Z++ switch is assigned to Z Home.  The Debounce interval is set to 1,000 and the Debounce Index is Zero.  A jpeg of my Homing configuration is attached.[/img] along with my XML config file.

When I press the limit switches, the LEDs in the Diagnostics screen properly indicate the Limit, and Limit/Home for each switch.

SYMPTOMS:

First, I click on the Machine Coord's button. When I click the REF ALL HOME button, the Z axis will move upwards at 50% speed.  When it triggers the Z++ Limit/Home switch, the system throws a Limit Switch Error and stops with the Reset button flashing.  Clicking the Reset button stops it from flashing.  Even with the Auto LimitOverRide toggled On, none of the axis will move with the Jog control and there is no error message displayed.  The only way to get the axis moving again (without turning everything off and back on again) is to click the Stop button.  But, when I click Stop, the axis I was trying to Home, which is sitting on the Limit/Home switch, drives on past the switch and crashes into the end of the axis.  I get this same behavior on all three axis.

I have tried referencing the axis individually on the Diagnostics screen.  90% of the time, when the selected axis triggers the Limit/Home switch, the system stops with a Limit Switch Error and will not complete the Home cycle.  Every once in awhile the the Homing will work properly and the axis will reverse off of the switch and then set the Machine Coordinate to Zero.  After hours of reading and trying different settings, I simply cannot get all three axis to Home properly.

Finally, if I do recycle power to the mill and restart Mach3, Homing still does not work properly.  If any of the axis are sitting on the Limit/Home switch (as indicated by the LEDs in the Diagnostics screen) and I click the REF ALL HOME button, I get the error message "Limit switch is Aactivated, check your axises position.  My understanding it that if an axis is sitting on the Home switch when Referenced, that it should back off the switch.

Your help in figuring out what is wrong will be greatly appreciated.

Regards,
Benson
« Last Edit: September 22, 2014, 03:15:20 PM by go930turbo »

Offline rdean

  • Active Member
  • Posts: 94
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #1 on: September 22, 2014, 05:53:05 PM »
On the "General Configuration" screen on the right upper side you will see an area "Noise Rejection".  Enter 2000 in each of these boxes and try to Home again.  I believe you are getting noise from the system that is causing the problems.   
If it now works then back off the setting to 1000 and try again. 
You want this as low as possible but still high enough to stop nuisance tripping.

Ray

Offline go930turbo

  • Active Member
  • Posts: 4
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #2 on: September 23, 2014, 01:02:14 PM »
Thanks.  I work with electronics and am familiar with debouncing switches and inductive noise.  Increasing debounce to 2000 did not make any difference.

Concerning noise:
Although the limit switch wires are not shielded, I have shielded wire to the Spindle and from the USB Card to the Stepper Motor Drivers. 
I doubled up on the ferrite rings and wire wraps for the AC supply to the spindle inverter.
All of the grounds are attached to a single point on the mill which is grounded to earth through the Spindle 110VAC ground wire.
The wires from the Stepper Motor Drivers to the Stepper Motors are not shielded...Should they be? 
I can add capacitors to the switch wires...what value caps do you recommend?  Or, would it better to replace all of the switch wire with shielded cable?

I just tried another experiment that worked (kind of).  Rather than share the Home switches as Limit switches, I disabled the Limit switch for X--, Y--, and Z++.  The Reference Home works repeatedly without failure.  This leads me to believe that noise is not the issue because the same switches with no change in wiring are working consistently.  When the Limit Signal is re-enabled and Reference is run, the "Limit Switch" error is thrown and the system stops.

How do I get into the guts of the REF ALL HOME macro?  I am wondering if the Home LED check comes after the Limit LED check so the software sees the Limit switch hit before the Home switch hit???

I suppose I can keep the Limit Signal disabled for the Home Switches and count on the Soft Limit to protect against crashes.  But, it bugs me when software doesn't work the way it is supposed to; leads me to believe there is another root cause that can lead to future unexpected problems.

Thanks for your time and help.  Any additional suggestions will be greatly appreciated.

Offline Chaoticone

  • Administrator
  • *
  • Posts: 5,459
  • Precision Chaos
    • View Profile
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline ger21

  • Global Moderator
  • *
  • Posts: 6,151
    • View Profile
    • The CNC Woodworker
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #4 on: September 23, 2014, 02:28:01 PM »
Quote
How do I get into the guts of the REF ALL HOME macro?  I am wondering if the Home LED check comes after the Limit LED check so the software sees the Limit switch hit before the Home switch hit???

Limits are disabled during homing, so what's likely happening, is that noise is triggering your limits after the homing is complete. Try a debounce of 5000-10000. That should tell you if it's noise or not.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline go930turbo

  • Active Member
  • Posts: 4
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #5 on: September 24, 2014, 08:38:52 AM »
I'll do some re-wiring and let you know how it turns out.

Offline Mogal

  • Active Member
  • Posts: 76
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #6 on: September 24, 2014, 10:51:39 AM »
Try testing your switches as well.
I had a switch that became slow to return to open causing this problem.
Replacing the switch did the trick.

Offline Bob Braeking

  • Active Member
  • Posts: 51
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #7 on: September 30, 2014, 05:45:30 PM »
Mechanical switches are not accurate.  If you change to proximity switches you will experience better accuracy and won't need to cheat with debounce as they are electronically actuated.

Bob

Offline go930turbo

  • Active Member
  • Posts: 4
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #8 on: September 30, 2014, 06:40:44 PM »
Thanks for the suggestion. I just completed rewiring the mill with shielded cable.  The limit switch cables are now completely separated from the Stepper power and signal cables.   As soon as I get back in town (gone to the  Road Atlanta car races) I'll see if the problem is solved.  If not,  I'll  put prox switches in.   Is there a particular brand or Part number you recommend?

Offline Bob Braeking

  • Active Member
  • Posts: 51
    • View Profile
Re: Homing Problem - Axis do not consistently back off the switch
« Reply #9 on: October 01, 2014, 03:03:47 PM »
I got mine from Arturo Duncan at www.cnc4pc.com. His part #A-60.  He also sells optical switches but I would not recommend that for a dusty environment.  My switches key off of aluminum angle.