Hello Guest it is September 28, 2020, 10:20:09 PM

Author Topic: Mach3 pause / idle couple second on every G2 or G3 code  (Read 3169 times)

0 Members and 1 Guest are viewing this topic.

Mach3 pause / idle couple second on every G2 or G3 code
« on: September 02, 2014, 10:36:42 PM »
Hi all,
a newbie here: just finish my first cnc router... happy, but...  :(
I can jog (manual) with no issue. but then when I run a simple gcode, I found this idle issue. I noticed the cnc idle for couple seconds when running the G2 or G3 code.
I did search in google but no luck for the clue/answer.

my cnc router configuration is: PC (WinXP) -> Mach3 -> Ethernet SmoothStepper (ESS) -> Gecko G540 (-> Super PID for Bosch spindle).
I run Mach3 and toolpath in Metric unit.

Mach3 latest version.
I am using ESS_v10p1d1g.m3p for the Ethernet SmoothStepper plugin since this is the one that could run slave homing (I am using 1 homing switch and 2 lead screws/stepper motors for Y stage).

Here I attached the xml I have and screenshoot on the Mach3 ESS general config and my PC's specs.

I really appreciate for any help or feedback.

thank you!
« Last Edit: September 02, 2014, 10:41:13 PM by DKautomation »
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #1 on: September 03, 2014, 11:10:13 PM »
Correction: my bad, the pause/idle for couple seconds happen on every next gcode line, not just specific G2 or G3, but any next line.

can anyone help? maybe a hint?
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #2 on: September 06, 2014, 12:12:17 AM »
bump...

please help...
anyone? nobody?

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #3 on: September 06, 2014, 03:50:25 PM »
Can you attach the code, also if possible can you shoot a vid and upload to youtube.
Might also be worthwhile looking at the CPU load whilst running the code to see if there is an issue there.
Hood
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #4 on: September 07, 2014, 04:46:55 PM »
hi Hood,

I am glad you are stopping by.

here is the video: https://www.youtube.com/watch?v=M_mMO8OCd4o&feature=youtu.be
and here I attached the code I was running.

fyi, the video is using a relatively new PC... which should be powerful enough in term of processor, memory and video card. I haven't put the license file as I want to compare if the 'demo' and the 'license' would make a different, and the answer is no.
I noticed this powerful enough PC's motherboard doesn't have parallel port.

additional info: I am using VC mode and disable backlash.

if you noticed on the video, there were few times the feedrate showing a very slow speed but then something goes very high speed (frame 1:42), which I just noticed when I watch this video.

please let me know any other (the right) question to inform you the detail.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #5 on: September 08, 2014, 01:50:17 AM »
Go to Settings page and turn off Tangential Control.

Hood
Re: Mach3 pause / idle couple second on every G2 or G3 code
« Reply #6 on: September 08, 2014, 07:23:16 PM »
hi Hood,

you the man!
it is running smooth now.

I wonder what 'Tangential Control' is. Will read about this feature tonight with happy face.

Thanks a lot!


(this thread considered close from know-on)