Hello Guest it is July 08, 2020, 08:03:19 AM

Author Topic: Steps/Inch on Lathe = 75,000; Seems a Tad High  (Read 6932 times)

0 Members and 1 Guest are viewing this topic.

Steps/Inch on Lathe = 75,000; Seems a Tad High
« on: August 30, 2014, 02:05:34 PM »
My last post got me no responses, but maybe I'll get lucky this time.

I am trying to adjust my mini-lathe steppers so the distances on the Mach3 screen have some relationship to reality. My z screw is 8 TPI, so 8 turns per inch. At 200 steps/turn, you would think I would be fine with 1600 steps/inch, but I am very close to correct with 6667 steps/inch. Obviously, something is messed up. I don't see any obvious relationship between 6667 and 1600. Maybe the correct figure is 6400, meaning I'm off by a factor of four for some reason, but I still have no idea what that reason is.

My x screw is 25 TPI, so presumably 5000 steps/inch. The figure I'm actually using is 75000!

Mach3 is set up for inches, but it says not to use this setting to change the way it reacts to G code. I can't find any other setting.

I am using a Kflop and Kstep. KMotion is set up in Step/Dir mode.
Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #1 on: August 30, 2014, 06:00:57 PM »
Are your drivers micro stepping types?  If so what are they set to?
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #2 on: August 30, 2014, 06:59:14 PM »
Thanks for replying. I will try to answer without saying anything stupid, but I can't promise anything.

The controller is a Kflop, which has a bunch of settings. The one I'm using says "Step Dir." There is also a microstepping setting, but the Step Dir thing was suggested to me.

I finally realized that Mach3 Turn does not have all the windows Mach3 Mill has. I went into the F6 window in Mach3 Mill, whatever it's called, and I made the mm/inch change. Then I went back to Mach3 Turn and tried the motors. The units are still way off.
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #3 on: August 30, 2014, 07:07:22 PM »
I stuck a G20 in the code to see if that made any difference, but it didn't.
Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #4 on: August 31, 2014, 03:00:04 AM »
Well, with microstepping the driver modulates the current to the stepper so as to divide each step into "n".  This means that the motor, from Mach's p.o.v., has 200n steps.  If your z axis was set to 4 micro steps per step, that would account exactly for what you see assuming that the steps per inch should be 6400.  Similarly, if n is set to 16 on the axis.  Try putting the numbers 6400/inch and 80000/inch into Mach and see if that gives the right calibration.  This assumes that the available numbers with the drive are 2, 4, 8, 16 etc which is normal.

Microstepping can give a small improvement in resolution at the expense of accuracy, but is mainly for smoother operation.  Setting it to 16 is a bit high I would have thought, 4 or 8 on each axis is about right.

Hope this helps.
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #5 on: August 31, 2014, 08:01:27 PM »
Thanks for the help. Do you have any idea where I would find "n" in the software? I don't see it in the KMotion config/flash screen.
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #6 on: August 31, 2014, 08:13:50 PM »
Well, I DID find one thing. According to a Dynomotion support page, the Microstepping setting, which appears to be fixed, is 16x. I assume this is the figure you're talking about. Maybe Mach3 and KMotion are not on the same page about this, i.e. Mach3 expects a lower number?

In the configuration area, there is a setting for microstepper amplitude, which sounds like a voltage to me. When I select "Step Dir" mode, this setting greys out, suggesting it doesn't apply. Since I'm in Step Dir mode, I am wondering what the deal is.

I have had some confusion because Mach3 Turn didn't show me all the configuration stuff that was available in Mach3 Mill. I just located an axis calibration tool in Mach3 Mill, which may solve the problem, if I can get a good travel measurement.
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #7 on: August 31, 2014, 08:34:59 PM »
Using the calibration utility and a dial indicator, I came up with 83333.33 steps/inch on x and 6475 on z. I got some figures that varied badly until I realized I wasn't taking the backlash out before each measurement. Tomorrow I'll see if this actually works.

Offline mc

*
  •  380 380
    • View Profile
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #8 on: September 01, 2014, 06:04:27 AM »
KStep microstepping is fixed at 16, but Mach doesn't know the difference. All Mach is interested in is how many steps it takes to move a known distance.

The amplitude setting that gets grayed out is of no interest in the KMotion Config&Flash screen. In StepDir mode, all you are interested in is the output channel (should be 8-11 for a single KStep), and the output gain if you need to swap axis direction. Remember that any changes you do on the Config&Flash screen will get wiped out by the settings in yout init.c file whenever you hit reset in Mach.

Anyway, using your figures-
Z-axis = 8tpi x 200 x 16 = 25600 steps per inch
X-axis = 25tpi x 200 x 16 = 80000

You're 6475 is only about a quarter of what it should theoretically be. You've not changed the output gain from 1 to 4 on that channel by any chance?
You can use output gain in open loop to increase the number of pulses, however it has no benefit and usually makes things more confusing when you come to setting up the axis or want to change something later.
Re: Steps/Inch on Lathe = 75,000; Seems a Tad High
« Reply #9 on: September 01, 2014, 08:04:03 PM »
I have been fooling with this thing a lot today.

First, I tried to get the backlash out. Measuring by turning the steppers while using a dial indicator, I came up with the figures of ~0.0005 on the x axis, which makes me wonder if it needs to be loosened, and .007 on z. I programmed this stuff into the backlash area of Mach3 and enabled it, but I do not know whether the program is supposed to be started with the backlash taken up or left in for the PC to take out, so for all I know, I could be doubling my backlash error.

I switched to "Exact Stop" mode because I read that this was necessary to make backlash correction work.

I have two programs that do nothing but move an axis (x or z) back and forth by 0.5". I ran those and came to the conclusion that the best steps/unit for x as 81540. Over half an inch, this agrees with the indicator to within a thousandth. Z is now at 6580, after measuring. I can't explain it.

I can't tell if backlash correction is working on x, since the backlash is really too small to distinguish from my own error in reading the dial from two feet away.

I have not changed the output gain. It's still 1.

Kmotion has a backlash function, but to use it, I think I have to know the steps/unit figure, so I haven't tried to use it yet. Again, I don't know whether you take up the backlash before starting the program.

Update: I turned off the backlash correction in Mach3, and now I'm getting a consistent 0.499" when I ask for 0.500", in EITHER direction. None of this makes sense.