Hello Guest it is May 25, 2019, 03:39:20 PM

Author Topic: X Axis Goes Backward in Mach3 Turn  (Read 1520 times)

0 Members and 1 Guest are viewing this topic.

X Axis Goes Backward in Mach3 Turn
« on: August 28, 2014, 01:46:46 PM »
I have a new mini-lathe running, but the x axis insists on moving backward. I am using Mach3 turn in Radius Mode. My controller is a Kflop with a Kstep.

I was told that in Mach3, +x means toward the user (away from the axis), because x is actually the radial direction. When I use the Turn Wizard or test code I wrote for myself, the x axis insists on moving the wrong way. The toolpath on the screen shows one thing, and the actual movement does another.

I changed the sign of the output gain in KMotion, and nothing happened. I also used the Reverse setting in Mach3. No change. I am reluctant to fool with the motor wiring.

Is there something I've overlooked?

This is my first CNC tool, and I have no background in engineering, so I really don't understand all the variables. I also have a problem with the steps per inch. Right now, my z is at 6667 with an 8-TPI screw, and the x is at 75000 with 25 TPI instead of the expected 5000. The movement magnitudes are nearly correct but I haven't calibrated them exactly.

Offline Hood

*
  •  25,819 25,819
  • Carnoustie, Scotland
    • View Profile
Re: X Axis Goes Backward in Mach3 Turn
« Reply #1 on: August 31, 2014, 04:33:15 AM »
Probably best to ask the Kflop people as it will be that that controls the axis direction and likely it has some specific way of setting things up.
Hood

Offline mc

*
  •  381 381
    • View Profile
Re: X Axis Goes Backward in Mach3 Turn
« Reply #2 on: September 01, 2014, 05:38:29 AM »
To change direction on an axis using a KFlop, in your init.c file, you need to invert the OutputGain setting i.e. if it's currently 1, swap it to -1.

Obviously swap init.c for whatever the name of your configuration C file is, which you can check by going to the Dynomotion plugin config page in Mach.
« Last Edit: September 01, 2014, 05:40:07 AM by mc »