Hello Guest it is October 16, 2019, 06:24:08 AM

Author Topic: Motor whistling only with Mach3  (Read 2260 times)

0 Members and 1 Guest are viewing this topic.

Motor whistling only with Mach3
« on: August 12, 2014, 04:36:02 PM »
Hello,

I have just built my home-made CNC and I have a set-up problem, I guess.

When I'm using my CNC with my manual interface, no noise. However, when I launch Mach 3 - it means I desactive the Reset button - my stepper motors make a strange noise. Even if that noise don't impede my stepper motor to work, it's quite... annoying.

Do you have any ideas where the problem could be ?


Thank you for your time !
Re: Motor whistling only with Mach3
« Reply #1 on: August 14, 2014, 11:46:54 AM »
I have read the Mach3 documentation and... nothing.

Maybe a video could help to describe the problem,

https://www.youtube.com/watch?v=qWu4QUgrB1Y
Re: Motor whistling only with Mach3
« Reply #2 on: August 14, 2014, 01:01:41 PM »
try retuning the motors.
hope this helps !
Kenneth
Re: Motor whistling only with Mach3
« Reply #3 on: August 14, 2014, 03:09:28 PM »
try retuning the motors.
hope this helps !

Do you mean try to modify stepper motor wiring ?!

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Motor whistling only with Mach3
« Reply #4 on: August 14, 2014, 04:23:55 PM »
What drives are you using. Some drives are just noisy, and there's nothing you can do about it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Motor whistling only with Mach3
« Reply #5 on: August 15, 2014, 07:05:45 PM »
Seem to recall that some, if  not all, of the TB type boards use full step when in external mode and that makes them quiet but when under Mach control the microstepping, set on the boards, comes into play and that can cause noise.
Could be totally wrong, often am ;)

Hood
Re: Motor whistling only with Mach3
« Reply #6 on: August 21, 2014, 07:13:03 AM »
under Config/Motor Tuning you're able to adjust the velocity and acceleration.
i had some noise and that helped me.
good luck !

try retuning the motors.
hope this helps !

Do you mean try to modify stepper motor wiring ?!
Kenneth