Hello Guest it is July 19, 2019, 05:22:51 PM

Author Topic: No Z Encoder in Mach3Turn, works in Mach3Mill  (Read 1574 times)

0 Members and 1 Guest are viewing this topic.

Offline B3030

*
  •  25 25
    • View Profile
No Z Encoder in Mach3Turn, works in Mach3Mill
« on: August 03, 2014, 04:38:59 PM »
I have a Sherline mill and a Sherline lathe that have both been converted to CNC and work great.  I've included a set of disconnects so one set of stepper drivers and BOBs (CNC4PC C11 and C10) will drive either machine.  I'm able to swap out a couple cables and use either machine.  All three steppers on the mill, and both steppers on the lathe have CUI AMT-102 encoders.  The X and Z steppers and encoders on both machines are wired exactly the same.  I use the same motor/spindle assembly for both.  

In the Mach3Mill Mill profile I'm able to see all three stepper encoders on the mill work on the Encoder DROs on the settings page.

In the Mach3Turn Lathe profile I only see the X Encoder work on the diagnostics page.  Cannot get Z encoder DRO to work at all.  I thought I had a bad encoder on the lathe Z stepper so I swapped the X Encoder wiring to the Z encoder and saw movement on the X encoder DRO so I'm sure the lathe Z encoder works.

** Now here is where it gets weird.  I left the lathe attached and opened the Mach3Mill profile.  Keep in mind the stepper and encoder wiring is that same.  Moving the lathe X Encoder changed the Mach3Mill X Encoder DRO on the Settings page.  This was expected.  Now, when I moved the lathe Z Encoder, the Mach3Mill Z Encoder DRO on the Settings page worked!  It didn't work using the Mach3Turn profile but works with the Mach3Mill profile.  Same wiring, different profile.  I triple checked the settings in the two profiles and everything I know that would affect the encoder DROs matches.  Really only the ports and pins on the Encoder/MPG's should affect the encoder DROs.

I have customized screensets for both the mill and lathe but I reverted back to the standard 1024 screensets to eliminate that.  Still no Z encoder DRO in the Mach3Turn profile.



Does anyone have an idea why the Z encoder DRO would work in Mach3Mill and not work in Mach3Turn?  

B3030

Offline B3030

*
  •  25 25
    • View Profile
Re: No Z Encoder in Mach3Turn, works in Mach3Mill
« Reply #1 on: August 06, 2014, 08:23:47 PM »
Lots of reads but no replies.

Has anyone ever connected encoders to lathe steppers to use the Encoder DROs in Mach3Turn?

B3030
Re: No Z Encoder in Mach3Turn, works in Mach3Mill
« Reply #2 on: June 29, 2015, 10:31:57 PM »
Hello B3030,

I'm also in the process of trying to configure Mach3 to run with encoders.I'm certainly not as far into my conversion as you, but I'd love to know how you got your pin numbers for the encoder/MPG settings in ports and pins menu.

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: No Z Encoder in Mach3Turn, works in Mach3Mill
« Reply #3 on: June 29, 2015, 10:55:39 PM »
MPG and encoders provide input to Mach. So YOU assign the pin #'s that will used for them.

RICH