Hello Guest it is July 17, 2019, 01:11:58 PM

Author Topic: Galil 2123 with AMP-20520 lathe Z axis DRO not working  (Read 9836 times)

0 Members and 1 Guest are viewing this topic.

Galil 2123 with AMP-20520 lathe Z axis DRO not working
« on: July 31, 2014, 01:19:56 PM »
I am setting up a lathe with a Galil DMC-2123 controller coupled to an AMP-20520 servo amplifier.  I am using electrocraft BLDC motors with HP HEDS encoders (500 cpr with index).  I have verified the encoder wiring is on the primary encoder channel for each axis and have tuned the motors on the bench and saved the values to the controller.

The problem that I am encountering is when I set up the motors for X and Z axis in the Mach3 turn profile.  Using the plugin configuration, I set Mach axis X to Galil axis X(A), Mach Axis Y to nothing and Mach Z axis to galil axis Y(B).  Ports and pins settings in Mach have X and Z motors enabled and 0 for pins and port.  When set up this way, the X axis DRO reads out any position change.  The Z axis DRO never changes from 0.0000, although the motor moves with the jog keys.  I can change which motor is assigned to which axis (Mach X -> Galil Y(B) and Mach Z -> Galil X(A)) and I have the same result.  X DRO reads fine, Z DRO never changes.  Motors move with Jog keys.  I have the motor options set to use the encoders for position feedback and actual speed.  Changing this value has no impact on the problem.

If I exit the turn screen and setup another profile that shows the Y axis DRO and configure the motors to operate on X and Y axis, the DRO for both X and Y operate as normal.  If I then configure the setup to utilize the servos on X and Z, I encounter the same issue as when in the "turn" profile.  X DRO changes, Z DRO does not.  Both motors will jog using the jog keys.

It acts like the active channels must be adjacent to one another in Mach for the DRO to work properly.

I tried setting up a bogus axis on the Y axis, but got errors from the controller that prevented any motion.

Any clues where to look to resolve this issue?  I could always just set up the motors as X and Y, but all the G-Code in the wizards and such use the Z axis.  I'd have to use the wizard in one profile, save the G-Code, edit to replace Z axis moves with Y axis moves, save, open a new profile, load the edited G-code, then run the program...tedious, but a functional workaround.
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #1 on: August 12, 2014, 02:52:33 PM »
Is there nobody that will help me?  I've not been able to resolve this issue and have encountered another along my path.

I installed an index wheel on the the lathe.  It uses a opto sensor and board from CNC4PC (C3).  I connected the output of this board to the Galil input 1.  I configured mach following the instructions in the Plugin manual.  The diagnostics screen in Mach indicates the program is seeing the pulse from the board, however, I have not been able to get the spindle RPM to display the actual RPM of the spindle.

I've followed the directions in the Mach 3 manual to set up the spindle.  I enabled the spindle, set the pulleys etc.  Nothing.

This has been a long process...and I'm approaching my tolerance level of trying to make the Galil board I have work with Mach 3.  I don't know if it's Mach 3, the plugin or me.  If I don't have some sort of break through soon, look for my board on Ebay.

Offline smurph

*
  • *
  •  1,106 1,106
  • "That there... that's an RV."
    • View Profile
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #2 on: September 22, 2014, 02:38:57 PM »
I have never tried a lathe setup with a 2 axis controller.  If you could setup the controller and map the axes to X->A, Z->B and provide a GalilDebug.txt file, that would help me understand what is going on. 

Steve
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #3 on: September 26, 2014, 02:11:24 PM »
I'll try to get something this weekend.

I've got the lathe running on Stepper motors for the moment.  Would love to have the servos...

Offline RICH

*
  • *
  •  7,341 7,341
    • View Profile
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #4 on: September 27, 2014, 06:08:00 AM »
Quote
I have not been able to get the spindle RPM to display the actual RPM of the spindle.
You need to turn the spindle on by clicking the spindle button on the screen.

RICH
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #5 on: September 27, 2014, 10:29:50 AM »
I see now that I was not clear in my description about the issue with the spindle...I did click the spindle on button on the screen...still no joy.
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #6 on: September 28, 2014, 05:43:49 PM »
I enabled the Debug and have attached it...

Offline smurph

*
  • *
  •  1,106 1,106
  • "That there... that's an RV."
    • View Profile
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #7 on: September 30, 2014, 12:49:16 PM »
Galil Error -2: Emessage = "96 SM jumpers must be installed for stepper motors."

Your Galil B axis motor type is set to stepper but no stepper jumper is installed.  If you are using amps with servos, change the motor type for the Galil B axis to "Servo" in the plugin configuration dialog.

Steve
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #8 on: September 30, 2014, 01:21:04 PM »
I'm 90% sure I set the motor type to servo in the drop down list in the config plug in screen...but I'll check tonight when I get home from work.

The motor did respond to the jog commands.
Re: Galil 2123 with AMP-20520 lathe Z axis DRO not working
« Reply #9 on: September 30, 2014, 11:26:35 PM »
I checked the plugin configuration settings and the Z axis is set to Servo as the motor type.  The Y axis IS set to Stepper in Mach, but nothing is assigned in Galil.  I've attached a screen capture of the config page.