Hello Guest it is October 18, 2019, 07:53:04 AM

Author Topic: Z plunges down by itself - buffer error  (Read 3350 times)

0 Members and 1 Guest are viewing this topic.

Z plunges down by itself - buffer error
« on: July 25, 2014, 10:04:30 PM »
HI Group, just restarted my CNC after 1 year, and it randomly plunges the Z axis !!!!  I clicked on Diagnostics tab and it said buffer overide - contact Brian -

I downloaded the latest update but it still does it - It never did this before.  Could it be bad keyboard or something?

 ??? ???

Thanks group,
AZ

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Z plunges down by itself - buffer error
« Reply #1 on: July 26, 2014, 04:53:24 PM »
Can you attach your xml please and I will see if I can find the issue.
Hood
Re: Z plunges down by itself - buffer error
« Reply #2 on: July 26, 2014, 07:06:36 PM »
Hi Hood - thanks for the prompt reply - sorry to ask but how do I generate the xml - maybe this will help - I went to ref all home and the Z plunges down, rather than up -

Thanks again
Anthony

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Z plunges down by itself - buffer error
« Reply #3 on: July 26, 2014, 07:32:03 PM »
Sounds like your Z is set up to go the wrong direction or possibly you are just homing it in the wrong direction.

If you look lower right on the screen in Mach you will see the name of the profile you are using. Close Mach then go to the Mach3 folderon your drive and look for a file of that name with a .xml file extension. Copy it to your desktop and rename to MikeIrvin.xml then use the additional options button on the reply page to attach it to a post.
Hood
Re: Z plunges down by itself - buffer error
« Reply #4 on: July 26, 2014, 08:09:28 PM »
Thanks Hood - that computer has no intenet - can I post it elsewhere? 

Thanks again,
Anthony

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Z plunges down by itself - buffer error
« Reply #5 on: July 27, 2014, 05:24:33 AM »
Copy it to a usb stick and transfer it to a computer that does have access.
Hood
Re: Z plunges down by itself - buffer error
« Reply #6 on: July 27, 2014, 05:46:02 AM »
HI Hood - as you requested -

Thanks again
Anthony
Re: Z plunges down by itself - buffer error
« Reply #7 on: July 27, 2014, 05:46:29 AM »
Hi Hood, I hope that is what you require.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Z plunges down by itself - buffer error
« Reply #8 on: August 01, 2014, 05:53:54 PM »
Sorry for the late reply, just not getting much time to come to the forum at the moment.
Will have a look at your xml and se if I can find an issue.
Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Z plunges down by itself - buffer error
« Reply #9 on: August 01, 2014, 06:10:07 PM »
Nothing is jumping out at me from first look at your xml.
I do notice you have the kernel set to 35KHz when you need well under 25KHz, so might be worth setting to 25 and restarting Mach.
You could also try reducing the look ahead to see if that helps.

Might also be worth checking the integrity of the Dir wiring on your Z axis or swapping over drives from another axis to see if the fault stays with the Z or moves with the drive.
Hood