Hello Guest it is October 14, 2019, 02:36:56 AM

Author Topic: Set Steps Per Unit function not accurate  (Read 3549 times)

0 Members and 1 Guest are viewing this topic.

Set Steps Per Unit function not accurate
« on: July 10, 2014, 02:58:24 PM »
I have been trying to calibrate using the Set Steps Per Unit tool in settings. I have been using something similar to ( http://www.amazon.com/iGaging-Absolute-Digital-Stainless-Accuracy/dp/B00KWCUZ4W/ref=sr_1_5?ie=UTF8&qid=1405017153&sr=8-5&keywords=digital+movement+slider ), except mine has 10 inches of movement. So I set it up so I can check within .001 accuracy axis movements. So the problem is, no matter how many times I calibrate and put in the suggested steps per unit I will be off when I try a different length of movement.

For example, I will choose X axis, tell it to move 6 inches, and input how for it moved, lets say, 6.008. Then accept the adjusted the steps per unit. Now I can Go To Zero and it will keep that 6 inches correct, but if I now choose to move it 10 inches, it will be off by a good margin, 10.036. So I adjust the steps for 10 inches, accept, then check 6 inches and it will now be off. Its like no matter what I do, the movement will not be correct if I choose a different length to calibrate.

I have tried lowering velocity, acceleration, but nothing seems to help. I have tried to compensate with Backlash function, but it doesn't seem to do anything at all. I have gone around and tightened everything I can on it and everything is tight and sturdy. I am using a table made by http://industrialcnc.com/routers/routers.php . It must be an older model because I cant see the exact one I am using but its most similar to the Apprentice 404 model.

I am not sure what to do here, its very frustrating because the table is mostly used to make circles in Baltic birch with a center hole. And while circles are not horrible, its still not reliable or accurate. These circles are used in a printing press so it has to be somewhat accurate, +0, -.020 tolerance. But the circles will differ by as much .050 and that in turn makes the center hole off also. I usually use a 30"x30" board, so I really only need to make it accurate over that length but I cant seem to get this dialed in. Any suggestions would be helpful.


-Tim

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: Set Steps Per Unit function not accurate
« Reply #1 on: July 11, 2014, 08:02:57 AM »
Tim,

Some suggestions:

1. Calculate the actual steps per unit. You will find info in members doc's or a Mach manual on how to calculate the actual value.

2. If you want to use the axis calibration feature in Mach under the Settings (Alt-6) tab / lower left hand corner  above reset button on the page.

- Before using it, you should move the axis in one direction to remove backlash from the axis.
- Follow the fly out screens, and idealy you should move the axis full length, say 9" in your case.
  ( say you move the axis 9", it actualy moved 9.036", that is the number Mach does the calc for, accept the  
   recommended steps.)
- You can repeat the above again if you wish. Steps per unit should be very close to actual if not right on.

You have now set the steps per unit based on a long movement thus any small movement inaccuracy is irrelevant / minor.
With steps per unit correct now check for backlash:
Move the axis all the way back and then move in the opposite direction , say 1" to remove any backlash.  
Now move in say 1" increments for say 6 moves, each move should be 1" on your attached scale.

Now move in the opposite direction to see how much backlash you have. Backlash is the diffference
of commanded to actual move distance.

Backlash compensation can be used but it is best to fix the problem.

BTW,
You can use a simple accurate ruler if you can move 30" to set the steps per unit.
Say you are +- 1/32" off with the 30" measurement, at  1" the error would be ie; 1/30 of 1/32"
thus you are close to +- .001" error in a 1" move.  ;)

Let us know how things go,
RICH
« Last Edit: July 11, 2014, 08:05:06 AM by RICH »
Re: Set Steps Per Unit function not accurate
« Reply #2 on: July 11, 2014, 12:37:03 PM »
I watched this video about backlash: https://www.youtube.com/watch?v=buXHZ_McbOY

So when I set Cycle Jog Step to .0005 and then jog, mach3s shows the first jog at .0005, but the next jog will show .0009, then .0014. Why is mach3 not jogging the specified step? It seems to lose .0001 every other step....Really confused now. Shouldn't mach3 only move at the specified amount?  Shouldn't each jog step be: .0005 > .0010 > .0015 > .0020 etc.

I am getting weird readings like .0005 > .0010 > .0014 > .0019 ...... > .0043 etc.

I "think" I am following the video correctly but something isnt adding up.

Re: Set Steps Per Unit function not accurate
« Reply #3 on: July 11, 2014, 03:49:54 PM »
I went and got it set up as good as i could in mach3. Went to Vcarve Pro, designed a single circle with a diameter of  5.7". Put the code into mach3 and let her rip. X = 5.705, Y = 5.701. I was pretty happy with that. Then I checked the diameter of the arches between X and Y and I got diameters from 5.694 to 5.725. Is there a way to tighten up the transitions between X and Y? The arches do not seem to be very uniform.




Also, I did end up using backlash compensation in mach3. You said its better to fix the problem, how does one go about fixing backlash? I am 99% sure every single screw/bolt is tightened. I had this machine dropped in my lap to work with and the owner has no idea about mach3 or computers, so I have had only a few months to teach myself how to use mach3 and vcarve. So I am pretty new to this still. Any tips would be appreciated.
« Last Edit: July 11, 2014, 04:07:25 PM by tmk-polar »

Offline rcaffin

*
  •  1,003 1,003
    • View Profile
Re: Set Steps Per Unit function not accurate
« Reply #4 on: July 18, 2014, 05:46:19 AM »
Sounds to me as though you have some serious backlash somewhere. That will always produce those results. And no, making sense out of it before you deal with the backlash is probably not possible.

Cheers