Hello Guest it is November 19, 2019, 12:08:16 AM

Author Topic: Uncommanded rapid Z plunges!  (Read 7767 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #10 on: June 23, 2014, 02:56:48 AM »
Can you try something. If you put Mach Offline and run the code does it still show this weird move in the Z DRO?

Hood
Re: Uncommanded rapid Z plunges!
« Reply #11 on: June 23, 2014, 03:23:51 AM »
Can you try something. If you put Mach Offline and run the code does it still show this weird move in the Z DRO?

Hood

Good thinking.... I've just tried this, and yes, the problem is still there. As soon as it does that head up at the end of the first cut, it ends up with the DROs being too far -ve. Hopefully that narrows things down a bit. It also means I can experiment with things here without risking a crash.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #12 on: June 23, 2014, 03:33:09 AM »
How about trying an older plugin,  go as early as you can find.
Hood
Re: Uncommanded rapid Z plunges!
« Reply #13 on: June 23, 2014, 04:06:21 AM »
I'll experiment with the Z-motor parameters first and see if I can tease out where the problem lies. I've got the Warp9 people looking into it too. I'm just surprised that what I thought was a mature product still has serious flaws like this.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #14 on: June 23, 2014, 04:43:16 AM »
I still use one of the first plugins that came out for the ESS, newer ones caused me issues but have not tried any for a long time.

I can say with almost certainty that it is not your hardware as the DRO is showing the movement, so it would seem it is either Mach sending the wrong command to the ESS via the plugin or it is the plugin itself, my guess the latter.
If however you are using Ver 066 of Mach then I would say that may be an issue because it has problems and in my opinion it should have been pulled a long time ago.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #15 on: June 23, 2014, 05:17:32 AM »
Ok I can say its not specific to plugin or Mach version but have been unable so far to work out where it is going wrong.
It seems as if there is some sort of shift going on but not sure why as there doesnt seem to be anything in your code.
For example it seems kind of like it is in Incremental mode but it is not according to Mach, will look and see if I can work out where its going wrong later.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #16 on: June 23, 2014, 05:42:36 AM »
Not found anything yet but can you make a new xml from scratch to see as there is definitely something very weird going on, even homing (I have disabled Home switches in Ports and Pins) and the DRO shows a value for Z and Y  when they  should be zero in machine coords.

Hood
Re: Uncommanded rapid Z plunges!
« Reply #17 on: June 23, 2014, 06:08:15 AM »
I have to go out on a job now, but I'll try that later. It's been homing fine, including a rapid move to 0,0,0 and it's repeated fine. I think this is to do with the setup of the Z move when it's on its own. If you halve the Zmotor tuning acceleration the fault remains, but if you change the maximum Z velocity to 1000 and leave the accel at 1000 then the problem goes away.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Uncommanded rapid Z plunges!
« Reply #18 on: June 23, 2014, 06:20:38 AM »
Ok I see now your Z is 4000 steps per unit and 2000mm/min. That equates to  133KHz, you have 128KHz set in the plugin for the Z.
Set the plugin to 256 KHz for Z, restart Mach and see if all is fine.
Hood
Re: Uncommanded rapid Z plunges!
« Reply #19 on: June 23, 2014, 10:47:03 AM »
Ok I see now your Z is 4000 steps per unit and 2000mm/min. That equates to  133KHz, you have 128KHz set in the plugin for the Z.
Set the plugin to 256 KHz for Z, restart Mach and see if all is fine.
Hood

Aha! That makes sense then, I was beginning to wonder what it could possibly be. Well spotted, I've tried that offline and it seems to fix the problem. I'd read the notes on that page and assumed that the settings were only going to affect the length of the buffer queue, that's what it seemed to imply to me.

Anyway, many thanks for helping with that, it's much appreciated.