Hello Guest it is July 07, 2020, 03:40:52 PM

Author Topic: Homing Not Working  (Read 1641 times)

0 Members and 1 Guest are viewing this topic.

Homing Not Working
« on: June 05, 2014, 07:20:16 PM »
Ok, I just bought my first "fully setup" new machine running Mach 3 and I have a problem.  It uses proximity switches as both homing and limits.  They seem to work fine as a limits, but only one axis actually homes properly.  The other two just keep going until I hit the E-stop button.  With the diagnostic page up they light the indicator, but it doesn't stop and home.  It just overshoots and keeps going. 

Suggestions? 

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing Not Working
« Reply #1 on: June 06, 2014, 04:55:37 AM »
Attach your xml and I will see if there is a problem in it.
Hood

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Homing Not Working
« Reply #2 on: June 06, 2014, 09:21:15 AM »
Also Bob, does this machine have any Brains or special macros that interfere with homing? I have seen people so all sorts of screwy things with the homing process, trying to be clever, and typically it just screws things up. I take it from you description that the machine uses eth same prox sensors are home and limit? Are all three axis tied together or do they go to separate inputs. Have you tried homing each axis individually?
Happy machining , Jeff Birt
 
Re: Homing Not Working
« Reply #3 on: June 30, 2014, 11:01:06 AM »
Found the problem.  The two that didn't work for homing were swapped.  They worked for limits, but not for homing that way.  Made it hard to find and trouble shoot.  It came that way.