Hello Guest it is May 23, 2019, 07:36:06 PM

Author Topic: ESS/MX3660 and Estop issues?  (Read 3266 times)

0 Members and 1 Guest are viewing this topic.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
ESS/MX3660 and Estop issues?
« on: May 30, 2014, 01:33:39 PM »
   I have a few machines that run Mach. All the do the mechanical work just fine, however the computers respond differently. I cant figure out why.

   At present I am testing a layout for my lathe. It consists of an ESS, an MX3660 (leadshine). The ESS has power full time (as long as machine is plugged in, in other words the power supply for the ESS is not connected thru my contactor)

   I have movement fine.

   My issue is that if I push the physical EStop button the machine quits (as it is contactor fed and the EStop kills the latching of the contactor) however nothing on the Mach screen would let you know that. Being suspicious that the contactor was somehow not letting the signal thru (since there was no power). I even pulled the EStops wiring connector from the MX3660 while leaving the contactor powered. I see that the MX3660 does disable the drive. But once again nothing on the Mach screen lets me know. I would think a restart should require an unlatching of the EStop button, pressing the reset button on the Mach3 screen then to press a momentary switch which energizes and latches the coils of the contactor.

   I have tried active low and high on the Estop button, smoothstepper and mach control of the Feedhold and everything and anything I can think of.

   Does anybody else see the Estop (the flashing of the reset button on screen) using an ESS? The switch works it just isnt getting thru to MACH or showing that it has anyway.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: ESS/MX3660 and Estop issues?
« Reply #1 on: May 30, 2014, 05:06:35 PM »
Mods, Can you move this to the SS section? Thanks
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,815 25,815
  • Carnoustie, Scotland
    • View Profile
Re: ESS/MX3660 and Estop issues?
« Reply #2 on: May 30, 2014, 07:47:25 PM »
I am not sure how you have your E-Stop wired but I can assure you that there is not a problem with E-Stop and ESS, mine has been working away perfectly for a good few years.

My E-Stop has two poles, one goes to the hardware E-Stop string, the other goes to Mach via BOB/ESS.

Hood
Re: ESS/MX3660 and Estop issues?
« Reply #3 on: May 30, 2014, 08:47:31 PM »
Yes, you need to set up your Estop as Hood suggests.

The Estop needs to remove the power as you are going. It also need to inform Mach3 that an Estop has occurred. This can be done by using a ESop button's 2nd pole to switch a logic level signal that gets to Mach3 via the breakout board and through the SmoothStepper.

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
ESS/MX3660 and Estop issues?
« Reply #4 on: May 30, 2014, 10:37:45 PM »
That is exactly how I have it wired. One set of contacts kills the latch to the contactor, the other pair go to pin 10 of Mach via the MX3660. Even if I pull the EStop connectors out of the MX3660, the drives disable but Mach never reacts differently. The reset does not flash. I swear the pins and inputs are set up. It is quite odd.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: ESS/MX3660 and Estop issues?
« Reply #5 on: May 31, 2014, 06:19:45 AM »
Presumably you are using Pin 15 to inform Mach3 that an EStop has occurred?

If so, have you confirmed with a multimeter that the MX3360 is driving pin 15 correctly when the MX3360 Estop input is activated?

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: ESS/MX3660 and Estop issues?
« Reply #6 on: May 31, 2014, 09:38:58 AM »
  Peter, I owe you a beer.

  I am not sure of why my Estop was set to pin 10 but it was. I even remember questioning it a few times. Now if I could remember the other machine that has this issue, I would check its pin setting too. Since all of my Estops actually break the latch for the contactor it never causes problems but I wondered why the screen doesnt show it.

  Again, Thanks. I read the MX3660 documentation again. I have no idea why I set it to pin 10 (if I did).
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: ESS/MX3660 and Estop issues?
« Reply #7 on: May 31, 2014, 12:02:29 PM »
All's well that ends well.

It's 2am an I'm off to bed. I've just finished watching Mick Rogers (Australian) win a mountain top finish stage in the Tour of Italy. What a ride!!

Cheers,

Peter
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com