Hello Guest it is October 16, 2019, 09:17:26 PM

Author Topic: abnormal condition exact stop vs cu mode  (Read 2467 times)

0 Members and 1 Guest are viewing this topic.

abnormal condition exact stop vs cu mode
« on: May 28, 2014, 08:03:57 PM »
Hello
Can some one tell me what ( exact stop vs cu mode ) means .And why is it stopping my milling with an estop


Thank you for your time

Marcel Beaudry

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: abnormal condition exact stop vs cu mode
« Reply #1 on: May 30, 2014, 03:27:59 AM »
Exact Stop (ES) means Mach will come to a halt and start again for each line of code.

Constant Velocity (CV)means Mach will blend the current line of code with the next and thus try and  keep to the commanded velocity from line to line of code.

Not sure what you are meaning about the E-Stop, is that with ES or CV? If ES then I suspect it may be vibration triggering a limit switch.
Hood
Re: abnormal condition exact stop vs cu mode
« Reply #2 on: May 30, 2014, 02:58:10 PM »
Hello Hood

Thank you for the quick reply .

Here is the program if you find something wrong with it please tell me

Marcel

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: abnormal condition exact stop vs cu mode
« Reply #3 on: May 30, 2014, 07:52:10 PM »
That code does not have G61 or G64 in it so whatever Mach is set as default, with regards ES or CV, will be how the code runs.

As I mentioned earlier neither should really cause you problems with regards E-Stop although if running G61 (Exact Stop) then your machine may be vibrating and causing limit switches to trip, its the only explanation I can think of.
Hood

Re: abnormal condition exact stop vs cu mode
« Reply #4 on: May 30, 2014, 08:35:33 PM »
Thank you

Marcel

Offline LGF

*
  •  37 37
  • can't sit still
    • View Profile
Re: abnormal condition exact stop vs cu mode
« Reply #5 on: April 23, 2015, 12:37:00 PM »
Guys

Kay so most of the issues on my machine was sorted, but because it's named "Evo1.Infinity" she' now slightly dead. Yes I had to fiddle with it. Here's what happened:

I got a VB script from the net for use with the "auto tool zero" button. Loaded (via edit button script) it on Tuesday eve, as soon as the spindle was to move down for the "auto set" in the config, there was this almighty blue flame. Kay so the wires for the flood pump 12v, had a short on the case frame that houses my cnc controllers, powersupplies etc etc, sorted that but seemingly this also flashed the Bios of the PC on which Mach was installed which resulted in a BSOD (Blue Screen of Death). So I had  to replace the hard drive, and rebuilt the PC (software wise). This afternoon I started the whole system up, worked fine, no issues. Then I go and load the VB script into the auto tool button and alas the axies all just went quiet with the condition normal (green) turned into the yellow abnormal condition.

I have read all the old posts, even on other forums and cannot get it sorted.

The difference is the condition abnormal button on my screen is static and does not flicker at all. I have tried all the advice from clicking set to normal, through to checking and rechecking all the settings, in the config (all the areas) disabled the probe switch physically as well as in the settings, however I don't think this is the problem, as when I do the auto set, it works fine, setting the port and pin and even "active low" if I had forgotten to do so.

I even opened the button script editor again and saved an empty file for the "auto tool zero" button, no change.  One thing I have to mention is that I just recently bought my license and also did the latest install of 3......66 of mach3. Again no problems whatsoever since I did this, however all started going South with the editing of the Script for the "auto tool zero" button. Could my PC have picked up a virus from the net that might have been in the VB script file or perhaps in the attempt to get some of the hardware drivers installed, that's causing this? As this is really the only cause I can muster from my broken brain now.

If there is any other recourse other than C4, please assist?
« Last Edit: April 23, 2015, 12:47:01 PM by LGF »
When I die, will someone please dress up as the Grim Reaper and attend my funeral. No need to do or say anything, just attend and stand a short distance away? PLEASE???