Hello Guest it is November 12, 2019, 06:52:09 PM

Author Topic: Inputs not working ? IP-S  (Read 2104 times)

0 Members and 1 Guest are viewing this topic.

Inputs not working ? IP-S
« on: May 19, 2014, 01:31:40 AM »
I am not seeing any inputs working (on the box leds or in mach3).

Per the cslabs drawing on wiring basic machine, it shows this

" 4.8 Digital inputs connector (0-15) (CSMIO/IP-S v2)", manual page 17.

Pin 1 input 0 (+) and pin 5 Inputs 0-7 (-).
So having a switch from pin 1. to pin 5 would be correct ?

Or ..
Pin 1, to the +24V line on the power supply.

4.15.3 Illustrative diagram of XYZ plotter (CSMIO/IP-S v2), manual page 24.
I am just trying to get inputs to work.

A wire connected from pin 1 to 5 or from +24v to pin1 both dont work.
No inputs.

Any ideas ?
A longshine stepper drive with differential outputs, and an ac brushless servo drive both work fine.


Re: Inputs not working ? IP-S - Solved by CSlabs
« Reply #1 on: May 19, 2014, 06:15:52 AM »
I got a new manual (V2) immediately.

The 24V PSU needs (-) to go to pin 5, for the inputs.
This solved it.

I was using an old manual.
Case closed.