Hello Guest it is November 12, 2019, 07:58:35 AM

Author Topic: Find Center Error "Probe Ignore, Activated at call for probe"  (Read 3314 times)

0 Members and 1 Guest are viewing this topic.

I am getting consistent failure when trying to find the center using both BlueTex and HOSS Mmach3 screen and the center finding macro. I have swapped out cables and computers to try and rule out the problem but now I am beginning to suspect it maybe my mach3 configuration.

I have tried both port 10 and 13 on the C10 board along with a 2.2K pull up resistor and every time I make contact between the port and ground the light in the probe area of the screen turns on as expected. Check out the video to see the strange behavior, any help would be appreciated. I have also posted the macro code below from the screens.

On another machine where this has worked successfully I noticed quick jogging back to the start position after making contact but this has never happened.

http://youtu.be/xSzCKSkJChI

---------------------------BlueTex Code ---------------------------------------------
Rem   VBScript To center probe inside a pipe

If GetOemLed (825) <> 0 Then       'Check to see if the probe is already grounded or faulty
   Code "(Probe plate is grounded, check connection and try again)"
Else
   FeedCurrent = GetOemDRO(818)    'Get the current settings
   XCurrent = GetDro(0)
   YCurrent = GetDro(1)

   Code "G4 P1"         'Pause 1 second to give time to position probe plate
   Code "F4"         'slow feed rate to 4 ipm

Rem   Probe left
   
   XNew = Xcurrent - 3      'probe 3 inches to left
   Code "G31 X" &XNew
   While IsMoving()      'wait for the move to finish
   Wend
   XPos1 = GetVar(2000)      'get the probe touch location

   Code "G0 X" &XCurrent      'rapid move back to start point

Rem   Probe right
   
   XNew = XCurrent + 3      'probe 3 inches to right
   Code "G31 X" &XNew
   While IsMoving()
   Wend
   XPos2 = GetVar(2000)

   XCenter = (XPos1 + XPos2) / 2   'center is midway between XPos1 and XPos2
   Code "G0 X" &XCenter      'rapid move to the x center location

Rem   Probe up

   YNew = YCurrent + 3
   Code "G31 Y" &YNew
   While IsMoving()
   Wend
   YPos1 = GetVar(2001)

   Code "G0 Y" &YCurrent

Rem   Probe down
   
   YNew = YCurrent - 3
   Code "G31 Y" &YNew
   While IsMoving()
   Wend
   YPos2 = GetVar(2001)

   YCenter = (YPos1 + YPos2) / 2

Rem   move to the center
   
   Code "G0 Y" &YCenter
   While IsMoving ()
   Wend

   Code "F" &FeedCurrent        'restore starting feed rate
End If
---------------------------BlueTex Code ---------------------------------------------

--------------------------- HOSS Code ---------------------------------------------
Rem VBScript To center probe Inside Diameter

CurrentFeed = GetOemDRO(818) 'Get the current feedrate to return to later
CurrentAbsInc = GetOemLED(48) 'Get the current G90/G91 state
CurrentGmode = GetOemDRO(819) 'Get the current G0/G1 state
CurrentToolDiameter = GetOemDRO(43) 'gets the current tool diameter

If GetOemLed (825) <> 0 Then 'Check to see if the probe is already grounded or faulty

    Call ProbeGrounded()
    Exit Sub

Else

    XCurrent = GetDro(0)
    YCurrent = GetDro(1)

    Code "G4 P1" 'Pause 1 second to give time to position probe plate
    Code "F4" 'slow feed rate to 4 ipm

Rem Probe Left

    XNew = Xcurrent - 3 'probe 3 inches to left
    Code "G31 X" &XNew
    While IsMoving() 'wait for the move to finish
    Wend
    XPos1 = GetVar(2000) 'get the probe touch location

    Code "G0 X" &XCurrent 'rapid move back to start point

Rem Probe Right

    XNew = XCurrent + 3 'probe 3 inches to right
    Code "G31 X" &XNew
    While IsMoving()
    Wend
    XPos2 = GetVar(2000)

    XCenter = (XPos1 + XPos2) / 2 'center is midway between XPos1 and XPos2
    Code "G0 X" &XCenter 'rapid move to the x center location
    While IsMoving ()
    Wend
    Call SetDro (0,0.000)
    Code "G4 P0.25"

Rem Probe up

    YNew = YCurrent + 3
    Code "G31 Y" &YNew
    While IsMoving()
    Wend
    YPos1 = GetVar(2001)

    Code "G0 Y" &YCurrent

Rem Probe down

    YNew = YCurrent - 3
    Code "G31 Y" &YNew
    While IsMoving()
    Wend
    YPos2 = GetVar(2001)

    YCenter = (YPos1 + YPos2) / 2

Rem move To the center

    Code "G0 Y" &YCenter
    While IsMoving ()
    Wend
    Call SetDro (1,0.000)
    While IsMoving ()
    Wend
    Call SetUserDro (1152,YPos1 - YPos2 + CurrentToolDiameter)
    Code "G4 P0.25"

    Code "F" &CurrentFeed 'restore starting feed rate
   Call ReturnG90G91State()
   Exit Sub
End If
 
Sub ProbeGrounded()
   Code "(Probe plate is grounded, check connection and try again)"
   Call ReturnG90G91State()
End Sub

Sub ReturnG90G91State()
   If CurrentAbsInc = 0 Then 'if G91 was in effect before then return to it
      Code "G91"
   End If
   If CurrentGMode = 0 Then 'if G0 was in effect before then return to it
      Code "G0"
   End If
End Sub   
--------------------------- HOSS Code ---------------------------------------------


 


Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Find Center Error "Probe Ignore, Activated at call for probe"
« Reply #1 on: May 17, 2014, 09:47:09 PM »
WHAT is all that ratatat noise ??? You should have smooth movement down to the contact point.

(;-)TP
Re: Find Center Error "Probe Ignore, Activated at call for probe"
« Reply #2 on: May 20, 2014, 09:07:33 PM »
Problem solved by resetting mach3 configuration. I suppose I change a default setting at some point.