Hello Guest it is July 21, 2019, 09:40:05 AM

Author Topic: Playing with Mach3 demo newbie CNC  (Read 1617 times)

0 Members and 1 Guest are viewing this topic.

Playing with Mach3 demo newbie CNC
« on: May 10, 2014, 11:14:35 AM »
Hello all.  I am newbie to CNC playing with Mach3 demo for now.

I am just fooling around trying to cut circles to better get a grasp of things, self learning.

I am using Solidworks/Solidcam and have created GCode to create a circle on a piece of stock.

When I load Mach3 everything is Zero and it shows the coord to be bottom left of the table.

When I load the gcode I am trying to set the starting point in the center of the piece as I indicated in Solidcam but it doesnt go there after loading the file.

Im not sure if this is a post processor issue or config of mach3 that I need to do ?  I tried to move to that point on the work piece as best as I can (its hard to tell from the table view if its exactly centered) but when I Zero the DRO's and regen tool path it will go a totally different spot than I want to set it at.

Thanks.

Offline BR549

*
  •  6,874 6,874
    • View Profile
Re: Playing with Mach3 demo newbie CNC
« Reply #1 on: May 10, 2014, 11:44:42 AM »
That is a Cam/post problem. It is not doing what you ask OR you are not telling to do it correctly.

Mach3 will only do what the Gcode tells it to do.

Most times in CAM you have an option as to where  POINT OF ORIGIN will be such as lower left, center of drawing or where you define it to be such as a center of a circle in the part.

Sometimes you can define the Point of Origin in the CAD side and then the CAM side will follow it.

Hope that helps, (;-) TP
Re: Playing with Mach3 demo newbie CNC
« Reply #2 on: May 10, 2014, 01:24:05 PM »
I did set that option where the origin would be center of the part.   
Re: Playing with Mach3 demo newbie CNC
« Reply #3 on: May 10, 2014, 01:46:55 PM »
I think I figured it out.   ill keep playing around with it.  I got it to center this time with fooling around with some settings in solidcam.

thanks!