Hello Guest it is November 20, 2019, 03:36:31 PM

Author Topic: THC Doesn't Move While Cutting  (Read 3414 times)

0 Members and 1 Guest are viewing this topic.

Offline BLM

*
  •  37 37
    • View Profile
THC Doesn't Move While Cutting
« on: May 07, 2014, 09:05:35 AM »
Hi there! I have a home built plasma table that I run with a Dell All-in-One/Windows 8.1, Mach3, Ethernet Smoothstepper mounted to a CNC4You BoB, and Proma THC. I used to use a USB BoB but I couldn't get THC to work at all and was told that Mach won't allow THC while using USB, so I bought a Smoothstepper. After I got the plugins all working and my drives all calibrated I can cut parts perfectly but Mach3 still doesn't allow THC/Z movement while running a part. It works if I run the test while the machine is idle and I can see all the inputs in the Diag. screen so Mach3 is picking up the signals. Seems like Mach3 is blocking the movement while a code is running. And yes, I tried the "Allow THC Movement When Not In THC Mode" on or off doesn't work. Does anybody out there use a setup like this that works? I'd like to hear from you! Thanks in advance!!!

Offline BLM

*
  •  37 37
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #1 on: May 09, 2014, 02:54:46 PM »
Anybody have any ideas????

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #2 on: May 09, 2014, 04:36:16 PM »
Could there be options in the SS config page that you need to turn on?

Hood

Offline BLM

*
  •  37 37
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #3 on: May 09, 2014, 05:33:06 PM »
Yes there is a THC box that needs to be checked and that is done.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #4 on: May 09, 2014, 06:04:49 PM »
Might be best either posting on the Warp9 forum or emailing Greg direct as afraid I have never used plasma at all.
Hood

Offline BLM

*
  •  37 37
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #5 on: May 09, 2014, 06:15:13 PM »
I've been communicating with them as well. It seems like there is a block in Mach3 that won't allow movement while cutting.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #6 on: May 09, 2014, 06:56:55 PM »
What is the antidive and THCspeed set to. Is the arc ok signal activating when you are cutting ?

(;-) TP

Offline BLM

*
  •  37 37
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #7 on: May 10, 2014, 09:28:09 AM »
I'm not sure what is meant by "antidive" but my THC speed is 20 and "THC Min Speed" is 60 percent.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #8 on: May 10, 2014, 06:37:43 PM »
Do you have the THC function turned ON?

Do you see an  ARKok  led turned on on the diagnostics screen  ?

 IF you are cutting do you see the THCup and THCdown led coming on and off indicating it shoudl be moving ?

(;-) TP

Offline BLM

*
  •  37 37
    • View Profile
Re: THC Doesn't Move While Cutting
« Reply #9 on: May 10, 2014, 07:09:20 PM »
Yes, yes, and yes. Thanks for the reply! This has been an ongoing problem since I got my table built in Feb. never have had the THC working properly. Some blame it on the Proma THC that I'm using. But that is doing its job because I can see the corresponding LEDs in Mach at the right times ect.....