Hello Guest it is December 15, 2019, 08:50:20 AM

Author Topic: No machine movement after resetting limits  (Read 1361 times)

0 Members and 1 Guest are viewing this topic.

No machine movement after resetting limits
« on: May 04, 2014, 01:01:16 PM »
Hi

My cnc was working fine. For a long time I was working with no limits enabled. I then decided
to enable the limits. I have no idea what I`ve done. Now it seems the dro show movement.
But the machine will not move. Port 1 shows 8 pins active. I did the driver test and all seems fine.
One thing I was using a photointerruptor  for the z axis limit. The wires fell off and I replaced them. But
now I wonder if the wiring to the limit is wrong. Could a incorrect wire orientation of the limit cause all this trouble.
Re: No machine movement after resetting limits
« Reply #1 on: May 04, 2014, 02:26:56 PM »
More Information: Just checked my sound logic board and the x axis led is not on.
That was the limit that the wires fell off. Is this a sign that the photointerruptor is
mis -wired
Re: No machine movement after resetting limits
« Reply #2 on: May 04, 2014, 06:37:47 PM »
Set Mach3 back to how it was before you decided to use limits, this will answer some of your questions.
Disconnecting all your limit wiring from your BOB will then leave your system working as before unless there's damage,
Regards,
Nick
Re: No machine movement after resetting limits
« Reply #3 on: May 05, 2014, 09:54:01 AM »
Hi
It was my parallel port. I have a second parallel port on the motherboard. But its never
been attached to a parallel port card. So I was using the wrong address. The first time
months ago when it was configured correctly. I didn`t make a backup of the xlm files.
When I ran into problems after changing setting I reverted to a older backup of the xlm.
Of course then I was using the incorrect port address.

Here is something of interest for troubleshooting:

Anytime I change to a different PC my biggest problem is setting up my parallel port. Just found this software
and tried it. Just create a directory in windows / program directory. Make certain the dll is placed in the same
directory as the drivertest.exe. I used windows 7 and it worked great


http://www.downtowndougbrown.com/2013/06/parallel-port-tester/