Hello Guest it is December 13, 2019, 06:06:12 AM

Author Topic: Plasma Z home speed homing in rapid  (Read 2761 times)

0 Members and 1 Guest are viewing this topic.

Plasma Z home speed homing in rapid
« on: May 03, 2014, 05:07:53 PM »
 This is my first experience with Mach3. Like the software, but more detailed instructions would be very helpful. I am setting up a plasma table with THC that has a floating head and a limit switch on the head for using as probe. Instead of connecting the switch to the "probe" under ports and pins i have the switch connected to the "Z home" pin.

 Here is my latest dilemma. When the machine homes Z axis it runs in rapid speed until the limit switch activates which many times ends up overrunning the switch and jamming the floating head. Under configure limit/home switches i can set the slow zone to whatever i want and mach3 just ignores this value and still homes in rapid speed. However if i run the axis way up and give a G92 Z.5 in MDI and origin the Z position to above the part and then home Z axis it will slow down to the homing speed after it reaches 0.0000 inches and continue down homing as it should. While running a program the torch head slams into the part when it homes and things go bad from there. I can slow down the Z motor max speed to allow for this problem but im afraid that will affect the speed at which my THC will adjust the Z axis.

 So what am i missing?

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Plasma Z home speed homing in rapid
« Reply #1 on: May 03, 2014, 05:20:41 PM »
Homing speed? Far right column in Config > Homing/Limits

Just a guess, as I don't use plasma.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Plasma Z home speed homing in rapid
« Reply #2 on: May 03, 2014, 05:25:18 PM »
Try it this way . In homelimits config Far right hand side of the window set teh HOMING speed as a % of rapid speed. I run at 20% on Z.

Then get into the habit of  coding the Zhome as G28.1 Z0.500. This is using the Z call as the GOTO point before it starts to actually home at the reduced speed. SO it will now rapid to the Z0.500 position then slow to the Defined homing speed towards the switch.

Just a thought, (;-) TP
Re: Plasma Z home speed homing in rapid
« Reply #3 on: May 03, 2014, 05:31:55 PM »
 I have the homing speed set to 20% of rapid and slow down position set to 1.0", rapid speed is 100"/minute. It ignores this for whatever reason.

 I will try giving a z position other than Z0 when calling up the g28.1 command and see what happens.

 I thought of adding some code to my post script to make it origin to 0 and then home from there as it slows down when it gets to 0. Something like this -

 G92 Z0
 G28.1 Z0

 But i would rather have it work properly in the first case.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Plasma Z home speed homing in rapid
« Reply #4 on: May 03, 2014, 07:44:23 PM »
YOu do not need to use the SLOW DOWN position setting. You are going to control that from the Gcode side.

(;-) TP
Re: Plasma Z home speed homing in rapid
« Reply #5 on: May 03, 2014, 08:14:12 PM »
 How does the G-code control the slow down for homing? The code simply gives a G28.1 Z0 command. I assume the control (mach3) simply executes that command. I also assume mach3 would over ride any feedrate commands during a homing sequence and use its feedrate parameters for homing.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Plasma Z home speed homing in rapid
« Reply #6 on: May 03, 2014, 08:22:30 PM »
READ THE MANUAL on G28.1. The Z call is the goto point BEFORE the homing begins. WHEN you called G28.1 Z0 you told it to rapid to Z0 before it even started to Reduce to homing speed. You probably ended up HITTING the plate at rapid speed

What you need to do is
G28.1 Z.500 the machine would rapid to Z.500 just above the plate then HOME at homing speed to the switch (top of material)
Re: Plasma Z home speed homing in rapid
« Reply #7 on: May 03, 2014, 09:49:47 PM »
 Got it. That explains it perfectly and easily understood.

 I did a search on the manual and there is only one single reference to G28.1 that i found and it doesnt explain anything about how it should be used.

 Thanks for the help im sure that is my problem.

Ive spent half my lifetime operating and programming CNC controls and im half embarrassed to admit i havent came across this before. All machines ive ran before you home the machine using the controls home sequence and after that if you want to return to the machines 0 coordinate (1st reference point) you give it a G28 Z0 or a G30 for second reference point.

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Plasma Z home speed homing in rapid
« Reply #8 on: May 03, 2014, 09:56:19 PM »
The problem starts when in Plasma you are using the Z home to FIND the top of the material NOT the Z top of stroke home position of a spindle.

Though SOME do use the G31 for the TOM routine and that leaves the Z home at the top of stroke for the torch (Safety move to top of stroke) gives you MAX clearance from the torch to top of material.

(;-) TP