Hello Guest it is May 21, 2019, 07:41:10 PM

Author Topic: stepper motor direction/s  (Read 2064 times)

0 Members and 1 Guest are viewing this topic.

stepper motor direction/s
« on: April 23, 2014, 09:37:20 AM »
i got my "buildyourownCNCrouter" back up and running. After finding the bad solder connections and re soldered them the 3 stepper motors run. BUT, I was experiencing when I set my speeds for each axis it worked great. When i pressed Return all home, I would have to play with each axis and finally get them to go to the home position. Once I did that and then try to jog, one or 2 of the axis would go in the oppisite direction. Now I have done something wrong (as usual) When I jog the Y axis to the Green Positive directiion it goes in that direction, when I jog the Red Negative direction it jogs in the Green positive direction. I can reverse 2 motor leads and all that does is make the Green go in a negative direction and the Red go in a negative direction. Why is this happening?? The brain for Mach 3 is out of wack, so is mine!!
« Last Edit: April 23, 2014, 09:43:04 AM by DarrylGF »

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: stepper motor direction/s
« Reply #1 on: April 23, 2014, 11:46:34 AM »
by the sound of it you have dodgy connections on your DIR chain somewhere.
Re: stepper motor direction/s
« Reply #2 on: April 24, 2014, 10:16:51 AM »
yes, it was a dodgy connection. Thanks Stirling. I was just going to change out the Y driver board with the spare. I didn't know it until the other day but the wire connectors are actually un-pluggable. I un-plugged the 3 sets. Got the power connector plugged into the spare board. Plugged in the motor wiring plug and was about to plug in the step and direction plug and noticed a loose wire. It was the ground wire for the direction  I fixed that, put the old driver board back in and all is fine.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: stepper motor direction/s
« Reply #3 on: April 24, 2014, 11:33:55 AM »
 :)

Thanks for getting back
Re: stepper motor direction/s
« Reply #4 on: March 26, 2017, 05:31:50 PM »
Hi
I'm having the same problem as (DarryIGF) was having my x and z work good but my y  direction goes in the wrong direction if I hit the up key it goes in the - direction I tryed everything switches out the controls,change the inputs on the breakout board,tested all the wiring .
please I need some help.
Allan P