Hello Guest it is May 21, 2019, 09:21:45 PM

Author Topic: No -X movment from GCode in Router Table  (Read 1314 times)

0 Members and 1 Guest are viewing this topic.

No -X movment from GCode in Router Table
« on: April 14, 2014, 12:55:27 AM »
Hello Mach3 World
I'm new to the site.  I'm a woodworker / Engineer and got it in my head to make wood gear clocks, and through a CNC router rig might be a interestng challange to cut the gears, so I'm an on the novice learning curve.

I picked up a table that looks to be from plans I've seen on web sites.  Replaced all the electrics and steppers, as the stuff that came with it were in poor condition. The controller board is a TB6560 board off Ebay.  Picked up a $9 tower at the second hand store to control it.

X Y Z axis all run fine from the puck and Mach3 from the keyboard and when zeroing.  No limt swithes yet, using soft 0.

The problem comes when running gcode.  -X movement is not executed, and the DROs reset, resulitng in the router migrating up the table.

Tried: Alternate tower, Alternate Card (first card had a bad Z axis and was replaced on warranty), traded out the X and Y connections.  No change so its not the computer, not the card and not the Stepper.  I'm guessing I've missed a setup nuance.
Per what I've seen  on the site, i've attached the XML config file for review.

Appreciate your insights.  The site is clearly a rich resource.  Thankyou to those "old hands" sharing your wisdom.

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: No -X movment from GCode in Router Table
« Reply #1 on: April 14, 2014, 04:46:05 PM »
So you can jog the X both positive and negative directions but running code it will only move the X in a negative direction?

Not sure what you mean by "and the DROs reset, " Can you try and be a bit cleaer on what you mean.
If you can also attach the code you are running .
Just to be clear when you mention -X, are you meaning X DRO values going negative or just the axis running in a negative direction, ie may still be positive values in the DRO but wont move so as values decrease?

Hood
Re: No -X movment from GCode in Router Table
« Reply #2 on: April 14, 2014, 08:01:26 PM »
Gday Hood, thank you for the assist.

I don't have a copy of the files I've tried, but its basically two  lines crossed at 45 degrees,  generated in Cam Bam and Lazy Cam, both demo mode, do have a license for Mach3.  Will attached one later, but the venerable Roadrunner.tap file shows this behavior.

Travel direction: Its just the opposite of your statement. Running G code it will only go +X direction, not in the -X, but all other controls move in all directions

RE the DROs,  Particularly the X readout goes to 0.  The Impact is when the code finishes, or is stopped,   I try to send the gantry back to my soft set Home, it returns to the original Y and Z position, but soft home value for X has reset to the last G code position.  That may be a clue that Mach3 is loosing the original X value somewhere.

Swapping the connections for the X motor and the Y motor on the controller resulted in the Y axis not moving in a -Y position, so I feel that eliminates a stepper fault.

The direction of the gantry and the DROs match, a movement in the defined -x,, -y and -z direction is reflected in the DROs by a declining number in the read out. 

Hope that helps.

I appreciate conversing with a fine Scot.  My ancestors hail from just outside Edinburgh.
Re: No -X movment from GCode in Router Table
« Reply #3 on: April 20, 2014, 10:49:35 PM »
Made a discovery while tinkering today.

Attached is my test file, cutting a square, going around it three times.

Just running it , the machine won't go in a "-x" (towards home).

If I click "Stop", then start the code again the code runs as expected.

I ran several files, first just running, then single stepping through the move to the first cut, click stop,the run normally, the the machine runs as expected.  Even ran an actually cut with the router.

That would infer that something gets turned off when stop is clicked?