Hello Guest it is October 22, 2019, 07:47:23 AM

Author Topic: Demo version to licensed, wizards not working?  (Read 2179 times)

0 Members and 1 Guest are viewing this topic.

Demo version to licensed, wizards not working?
« on: April 06, 2014, 09:31:36 AM »
I had a friend that had an ACT DMC III that his work was going to get rid of so he called me up.  The machine was going to come minus the computer but with the software (mach3).

So I did some reading and setup a computer with the 32 bit version of windows XP and downloaded the demo version of Mach 3, to see what I can learn before I have the machine.

A week goes by and The machine is connected to the computer I had set up and he downloads the files that he has to the computer.  Where it had read "demo" it now reads the name of the machine builder.  At this point it seems something's are not working as they should but I chalk it up to not knowing what I am doing.

Yesterday my 2 yr old is sick so I am inside with her and decide to put MACH3 on my laptop (hope that is ok) to see if I can create a few programs to try out in the shop during nap time.  I use the files he had brought that already had the license.dat file.

Everything works fine on the laptop, it's pretty simple with the wizards functioning and the programs run on the machine computer fine.

Now how do I get the machine computer to let the wizards work?  You can adjust settings and even save them inside the wizards just can't post the Gcode.  Do I need to uninstall everything and try again, or is there yet one other thing I am missing?

Again, thanks for the help.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Demo version to licensed, wizards not working?
« Reply #1 on: April 06, 2014, 10:18:57 AM »
Hopefully someone with more experience will chime in but I will give you my take.

1. I am not sure if a Mach license is transferable but most likely it is. I do know that if you have a license, you can have it on as many computers and machines as you desire. Quite generous IMO.

2.Doing a fresh install always seems to help when things go wrong. Always try to keep a back up of your last working xml files. Mach does this so really you just need to know where to get it.

 It sounds like you already figured out my last suggestion to transfer the file from 1 computer to the other.

 Did the original computer have the wizard and appeared to work but wouldnt save the file? 

Wish I could help more.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Demo version to licensed, wizards not working?
« Reply #2 on: April 06, 2014, 10:37:40 AM »
The way it looks to me is that the license was to ACT (folks that made the mill in question) not the business where it came from.

On a fresh install, do you just uninstall and reinstall or are there other things that need to be done?

You can change the values in the wizards and even save them so they are there next time you open it, they just won't post any code.

Not a huge deal because I do have it working on one computer, too bad it doesn't have a paralell port or I would just use it.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Demo version to licensed, wizards not working?
« Reply #3 on: April 06, 2014, 11:21:37 AM »
The Newfangled Add On wizard requires a separate license.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Demo version to licensed, wizards not working?
« Reply #4 on: April 06, 2014, 11:55:27 AM »
These are the regular ones that were created by different individuals.
Re: Demo version to licensed, wizards not working?
« Reply #5 on: April 07, 2014, 06:46:52 PM »
Uninstalled it and reinstalled, it works now.

Thanks.