Hello Guest it is December 10, 2019, 03:06:33 PM

Author Topic: Mach 3 machine coordinance  (Read 1817 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 machine coordinance
« on: April 02, 2014, 08:06:02 PM »
I would like to find a way to zero my machine coordinance.
I have tried to ref all home  and that does not work.
I want to set my tool in a zero location on my table and the set machine coord. to that spot as zero.
How can I accomplish this so that my part zero and machine zero are the same?
Re: Mach 3 machine coordinance
« Reply #1 on: April 02, 2014, 08:34:29 PM »
First, make sure you do not have any Home switches enabled.
Jog to where you want 0,0,0.
Press the ZERO X,Y and Z buttons by each axis DRO.
Press the Ref All Home button.

Toggle the Machine Coords button and you will see that Machine and Part Coords are both the same.

Russ
Re: Mach 3 machine coordinance
« Reply #2 on: April 02, 2014, 08:40:52 PM »
Or, if you are using the home switches, after homing,  jog to your Part 0,0,0 then switch to Machine Coords and make note of the Machine coord values and enter them in the Home Off boxes on the Homing page. (might need to invert the values). ie: If your Part X,0 is at Machine 10, then put -10 in the Home Off box.

Russ
Re: Mach 3 machine coordinance
« Reply #3 on: April 03, 2014, 12:09:10 PM »
I have tried the way you describe and it does not work
When I zero mt dro's and hit ref home the dro starts counting and never stops/100,000 plus
before I get to the mach coord button






 
Re: Mach 3 machine coordinance
« Reply #4 on: April 03, 2014, 02:31:36 PM »
Did you disable your home switches ? The only way it will head for home is if they are enabled, otherwise, it will set MACH COORDS to 0,0,0 right where it's at.
If you hit REF ALL HOME and the DRO's move but the table doesn't, then you have other problems.

Is it the stock screen ?

Russ
Re: Mach 3 machine coordinance
« Reply #5 on: April 03, 2014, 02:47:10 PM »
You might have improper pin assignments and enabled homing. That would make the dro's count with no table/machine movement.
Either way, check Config / Ports and Pins / Input Signals and make sure the red x is at the axis home box.
Russ
 :)