Hello Guest it is December 14, 2019, 02:09:51 AM

Author Topic: Pulsing too fast, kernal speed, motors stalling  (Read 5440 times)

0 Members and 1 Guest are viewing this topic.

Pulsing too fast, kernal speed, motors stalling
« on: March 22, 2014, 02:33:54 PM »
My old HP laptop running mach2 died and I had to set up a newer, faster Compac EVO 610c and Mach 3 Win XP. The last time I ran it, it seemed fine. Today when I went to jog it upon start up, the motors would stall and miss steps. Ran the driver test and it bounced between pulsing too fast & normal, I tried disabling various unused hardware items like the IR port etc. Uninstalling software, etc. no luck. Installed the various drivers related to the laptop & uninstalled them.

 All this at 25kHz kernal speed. On a whim I tried selecting the different kernal speeds during the driver test and as I increased, the display smoothed out an stabilized  for all but the top kernal speed. I went back to Mach and changed the kernal speed in the setup and it seems to jog just fine now but I don't want to risk a crash or stall.  Anyone have any insight into this issue? I seem to recall having the problem initially upon installing Mach 3 but when I installed the sound card driver, everything worked. It's not an issue with the printer port voltage, I drive a breakout card with it to get proper port levels to the controller. Help!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Pulsing too fast, kernal speed, motors stalling
« Reply #1 on: March 23, 2014, 05:53:18 AM »
Laptops are not officially supported by Artsoft unless with an external controller, the reason being is they can be very problematic when using the parallel port driver due to the power saving features inbuilt. Some laptops work fine, some dont, some you can get working and some you cant.
You will just have to try and see if it works, if not then you will either have to get another computer or use an external controller.
Hood
Re: Pulsing too fast, kernal speed, motors stalling
« Reply #2 on: March 23, 2014, 08:56:05 AM »
It appears that the issue is related to the video driver. When I uninstalled the ATI Radeon 7500 driver package and let windows default to a VGA driver, it solved the problem. I have a SmoothStepper but I haven't had time to put it in service.
Re: Pulsing too fast, kernal speed, motors stalling
« Reply #3 on: April 22, 2014, 11:49:37 PM »
So the problem showed up again. But I finally nailed down what causes it but I don't know how to fix it. @25kHz kernel speed I get pulsing too fast errors, motor stalling. If I run the driver test and try 45kHz kernel speed, I get a System Excellent for the duration of the test, likewise if I choose 45kHz in Mach on the config page, the machine operates normally.

What I discovered was if I have my USB thumb drive that I use for my Gcode files plugged in, everything works as it should at 25kHz. If I unplug the thumb drive, I get the pulsing too fast, alternating with good pulses. It's almost as if the computer is polling the USB port resulting in errors. But yet with it unplugged, I can get it to function at 45kHz kernel speed.

The BIOS has an option for USB Legacy support Enabled or Disabled, I've tried it both ways but it made no difference.

Anyone have any thoughts? I'm going to run USB deview tomorrow and delete all the USB devices that show up.

Anyone know if SmoothStepper installs any kind of Windows drivers other than the Mach driver in the Mach folder? I tested a SmoothStepper board on this computer but haven't used one. I removed the SS driver file from the Mach folder.
Re: Pulsing too fast, kernal speed, motors stalling
« Reply #4 on: April 23, 2014, 07:18:03 PM »
I finally FINALLY ran down the problem. First I used the FTDI uninstall utility to remove the smoothstepper drivers. That had no effect. Next I used USBDeview to remove all the USB devices that had ever been connected. That made no difference. I knew it was USB related since without the thumb drive I got the pulsing too fast error.  I went into the System Hardware menu and in Device Manager I selected Universal Serial Bus controllers. Looking at each of the USB Root Hubs there was a power management tab, selecting it and the un-ticking "allow computer to turn off this device to save power" after doing this, the pulsing too fast ceased. It bounces between system stable and system excellent. With the thumb drive plugged in, it's a steady system excellent. Hope this helps another laptop user.