Hello Guest it is January 18, 2020, 07:17:28 AM

Author Topic: 4th axis turns for 359° instead of -1°  (Read 6967 times)

0 Members and 1 Guest are viewing this topic.

4th axis turns for 359° instead of -1°
« on: March 20, 2014, 04:02:32 AM »
Hello, I am trying to use the 4th axis with solidcam, and in fact in works, but when it does movement outside the material a good thing would be that it wouldn't do a full rotation when it goes (for example) from 355 to 0.
Here is a gcode example:
Code: [Select]
S1000 M03
G00 G54 G90 X21.5875 Y0. A-88.588
G43 H1 Z30.
G01 G94 Z13. F300.
A270. F600.
G00 Z35.
X19.5875 A-88.588
Z33.284

Thanks in advance !

Offline RICH

*
  • *
  •  7,401 7,401
    • View Profile
Re: 4th axis turns for 359° instead of -1°
« Reply #1 on: March 20, 2014, 07:08:14 AM »
A few choices are allowed in configuration. See "Rotational" selections above Screen Control on the configuration page  and have a read of what they do in the manual .

RICH
Re: 4th axis turns for 359° instead of -1°
« Reply #2 on: March 20, 2014, 07:12:47 AM »
 This works with G0 rapids, but not with G1's.
(on the Gen Config page)

Russ
 :)
Re: 4th axis turns for 359° instead of -1°
« Reply #3 on: March 20, 2014, 07:14:37 AM »
ooops, that's one FAST bug you're riding there Rich.  :D

Russ
 :)

Offline RICH

*
  • *
  •  7,401 7,401
    • View Profile
Re: 4th axis turns for 359° instead of -1°
« Reply #4 on: March 20, 2014, 07:22:03 AM »
Hey Russ, no need for speed just better to enjoy the ride. >:D  :D

Have Cabin Fever yet?

RICH

Offline RICH

*
  • *
  •  7,401 7,401
    • View Profile
Re: 4th axis turns for 359° instead of -1°
« Reply #5 on: March 20, 2014, 07:26:46 AM »
Just somehing to consider on the rotation. If you have backlash it may be better to have it rotate in the same direction so  it is taken up.

RICH
Re: 4th axis turns for 359° instead of -1°
« Reply #6 on: March 20, 2014, 07:29:07 AM »
 no need for speed   >:D  :D

Have Cabin Fever yet?

RICH

Maybe that's not a bug ... .it's a TURTLE.

Heck yes, I'll be there !
You get us vendor passes yet ?

Oh yeah, good point on the backlash !  ;)

Russ
Re: 4th axis turns for 359° instead of -1°
« Reply #7 on: March 20, 2014, 09:48:39 AM »
Sorry in advance for the following questions but maybe I'm too "newbie"...

Quote
A few choices are allowed in configuration. See "Rotational" selections above Screen Control on the configuration page  and have a read of what they do in the manual .
I don't find the setting nor "screen control" and what is the configuration page (settings or config menu) ?

Quote
This works with G0 rapids, but not with G1's.
(on the Gen Config page)
Same question for "Gen config page" do we speak about mach3 ?

EDIT: I seems that I have an old version of mach3, will try to update...


« Last Edit: March 20, 2014, 10:01:13 AM by greg2fs »
Re: 4th axis turns for 359° instead of -1°
« Reply #8 on: March 20, 2014, 10:18:25 AM »
(menu bar) Top left of the screen, click on Config.
Then in the drop down, click on General Config.
Then near the lower right you see the Rotational settings.
Russ
Re: 4th axis turns for 359° instead of -1°
« Reply #9 on: March 20, 2014, 10:26:47 AM »
 :)

If your version is VERY old, Mach2, it will be a bit different.
If this does not fix you, post your version .... or like you say, update to a newer one.
Russ