Hello Guest it is October 26, 2021, 04:30:16 PM

Author Topic: Tool DRO problem  (Read 4807 times)

0 Members and 1 Guest are viewing this topic.

Tool DRO problem
« on: March 09, 2014, 07:48:36 PM »
I'm relatively new to MachScreen. So, here's my question: I placed a "Tool#" DRO & a "Tool Dia" DRO on my screen and followed up with the "Function Code" for  both. Now, does the "function" read the G-ode and list the tool number & diameter in the DROs, or does something else happen? DRO remains 0.0000. I ran a program listing T1 as the tool (with tool # & Dia.) and the Tool# & Tool Dia DRO's remains 0.000. If I try to enter a number in the Tool# DRO, it returns to 0.0000. The DRO for TOOL DIA excepts the number entered. This is making me CRAZY!!   >:(
"For those who fought for it, Freedom has a flavor the protected will never know"

UNKNOWN

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: Tool DRO problem
« Reply #1 on: March 09, 2014, 09:28:41 PM »
I believe the tool # DRO displays the current tool #, which is also displayed in the corner of the toolpath display. To change it, you need to do an M6 Tx.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Tool DRO problem
« Reply #2 on: March 10, 2014, 10:37:15 AM »
Gerry,
Thanks for the quick response! The tool number shows up in the top corner of the tool path, but all I get in the Tool# DRO are zeros. I have the /M6 T# coding in the program, it just does not read it into the DRO. ???
Bob
"For those who fought for it, Freedom has a flavor the protected will never know"

UNKNOWN

Offline ger21

*
  • *
  •  6,293 6,293
    • View Profile
    • The CNC Woodworker
Re: Tool DRO problem
« Reply #3 on: March 10, 2014, 11:39:47 AM »
I don't use machscreen, but it sounds like you have the wrong DRO function.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Tool DRO problem
« Reply #4 on: March 10, 2014, 12:30:44 PM »
I have tried both (only) Tool #DRO's listed. Neither seems to work.

1:  Current tool number DRO, Standard Code= 24, Format= %4.4f
2:  Tool number DRO, OEM Code= 824, Format= %4.4f

Open to suggestions!
"For those who fought for it, Freedom has a flavor the protected will never know"

UNKNOWN
Re: Tool DRO problem
« Reply #5 on: March 18, 2014, 08:29:47 AM »
don't know if you solved your problem but....
make sure you're editing the correct profile. i did
that. work a whole day then found was working on
wrong profile. also,if you have mach3 open, you
have to reload the saved set file.
Good Luck
Kenneth
Re: Tool DRO problem
« Reply #6 on: March 18, 2014, 10:26:14 AM »
Got it to work late yesterday! Still not sure how!! I really like this program though!

Thanks!
Bob
"For those who fought for it, Freedom has a flavor the protected will never know"

UNKNOWN